Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: We have added a new template into Divi's Theme Builder (Divi -> Theme Builder in the Admin).

We were able to find the text from the templates in the String Translations, however, after translating the text, the translations don't show up (we're still seeing the original text).

We have cleared the cache on the backend and the frontend but that didn't help.

Solution: Please go to WPML -> Settings -> Post type translation, and make sure to set all the below post type to "Translatable - only show translated items":

- Theme Builders (et_theme_builder)

- Templates (et_template)

- Header Layouts (et_header_layout)

- Body Layouts (et_body_layout)

- Footer Layouts (et_footer_layout)

After that, go to Translation Management -> Dashboard, select the desired template types and send them for translation.

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Jeremy 3 months ago.

Assigned support staff: Mateus Getulio.

Author Posts
April 20, 2021 at 1:44 am #8576319

Jeremy

Hello,

We have added a new template into Divi's Theme Builder (Divi -> Theme Builder in the Admin).

We were able to find the text from the templates in the String Translations, however, after translating the text, the translations don't show up (we're still seeing the original text).

We have cleared the cache on the backend and the frontend but that didn't help.

April 20, 2021 at 9:04 pm #8585383

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Jeremy,

Thanks for contacting our support forum.

Have you already translated these templates? Please go to WPML -> Settings -> Post type translation, and make sure to set all the below post type to "Translatable - only show translated items":

- Theme Builders (et_theme_builder)

- Templates (et_template)

- Header Layouts (et_header_layout)

- Body Layouts (et_body_layout)

- Footer Layouts (et_footer_layout)

After that, go to Translation Management -> Dashboard, select the desired template types and send them for translation. Please try these steps and tell us if you can't still see the translations on the front-end.

Also, by looking at your debug info, we can see that you're running outdated versions of WordPress and WPML plugins. Let's try to update these components to see if this gets corrected:

**IMPORTANT** - Please make a backup of the site files and database before doing the following procedure.

- Inside your wp-admin please go to Dashboard -> Updates
- Then click on the "Check again" button
- Update WordPress
- After that please select every WPML plugin available in the list and then click on "Update Plugins"

Give it a try and see if the problem persists. Let us know.

Kind regards,
Mateus.

April 21, 2021 at 12:51 am #8585809

Jeremy

After we made those settings changed, the footer has disappeared from both English and French translation.
hidden link

We updated all the WPML plugins too.

April 21, 2021 at 3:46 am #8586307

Jeremy

My issue is resolved now. Thank you!