Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Otto 1 year, 2 months ago.

Assigned support staff: Otto.

Author Posts
October 14, 2017 at 11:39 pm #1401118

Puntorosso

Hi,

I have a problem with a Divi/Toolset/WPML setup.

Steps:
- create a custom post using the Divi builder with only a text module and publish it.
- open a translation and I see the Title and the Text fields.
- open again the original post
- disable the Divi builder (the text module is automatically inserted as standard WordPress body content) and update.
- open the translation and I see only the Title, but the Text field is not displayed.

Here is a screencast

hidden link

Thanks

Best

October 16, 2017 at 2:46 pm #1402165

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Please try the following:
-Go to pages, switch to German and delete the translated page
-Empty the trash
-Go to WPML > Packages and delete the package that belongs to the page (you will find it using the page ID)
-Go to the original page and update it
-Edit the translation again

Is it working fine now?

Let me know your results, please.

Kind Regards,

Otto

October 16, 2017 at 3:00 pm #1402188

Puntorosso

Hi Otto,

yes it works, but has 2 main inconveniences:

1) It's a very tedious procedure to do when you have a bunch of posts.
2) The german translation get lost.

To me it looks like a bug in the Translation Management.
Do you think it will be addresses in the future?

Thanks

Best

October 16, 2017 at 5:47 pm #1402469

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Sure, I understand.

I am not sure if it's a bug, and if we will be able to handle it.

I will check with our second tier support.

But before, I would like to take a deeper look at the issue and see if I can provide a suitable workaround. Is it possible for you to share a copy of the last version of the theme, so I can try it locally and investigate further?

I'll set next reply as private, so you can share a download link safely.

Once the issue is solved I'll delete the files.

Thanks for your cooperation.

Kind Regards,

Otto

October 16, 2017 at 6:13 pm #1402517

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I am sorry but the upload failed, probably due to the file size.

You may need to use DropBox, Google Drive, or similar services.

Kind Regards,

Otto

October 16, 2017 at 6:38 pm #1402555

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks a lot.

I am not sure this is a problem with WPML.

In fact, what Divi does when you switch to the default editor is remove all the content from the Divi editor and revert to the previous content.

When switching to the default editor to the Divi editor, the previous content of the post is inserted into a text block. But if you edit this text block (using the Divi editor) and then revert to the default editor, you will lose any edit you've made. And the translations too.

So, the content in the Divi editor and in the default editor are different for Divi. When switching, there is a warning that you will lose your content. In your case, it looks like you are not losing content because the previous content did not change.

Try the following, please:
Before switching to the default editor, edit the content of the text block using the Divi editor. You will see that you will lose all the changes. And the same happens with the translations.

So, I think that this is a workflow issue. Not a bug nor a compatibility problem.

Please, let me know what do you think about it.

Thanks!

Kind Regards,

Otto

October 16, 2017 at 6:59 pm #1402570

Puntorosso

I understand your point.

My complain is not about losing text or translation (even if that would be nice if I wouldn't).
My problem is that once I switch from Divi Builder to the standard WordPress content editor, the WPML Translation Manager shows only the Title and the Categories fields.

I don't have any Content field where I can translate it!

October 16, 2017 at 7:04 pm #1402576

Puntorosso

Let's forget Divi.

- I have now a post with standard WordPress Title and Content fields.
- I update the post.
- I click on a language to translate it.

= WMPL Translation Manager has to show me both fields to translate.

Sadly it doesn't happen.....

October 16, 2017 at 7:30 pm #1402594

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

I forwarded the ticket to our Themes & Plugins Compatibility Team and they will investigate further and contact the author if needed.

Kind Regards,

Otto

October 16, 2017 at 7:33 pm #1402597

Puntorosso

Thanks Otto.

October 17, 2017 at 1:10 pm #1403400

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Just an update.

The issue has been escalated to our development team.

I will be solved in a future version, but we can't tell you which one as it depends on many factors.

I will keep you posted about the progress of the issue.

Have a nice day 🙂

Kind Regards,

Otto

October 17, 2017 at 1:21 pm #1403411

Puntorosso

Thank you Otto!

Have a nice day.

Best

October 11, 2018 at 11:33 am #2807852

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

This problem will be fixed in the next WPML version.

Have a nice day 🙂

Kind regards,

Otto