Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Bigul 3 weeks, 5 days ago.

Assigned support staff: Bigul.

Author Posts
September 10, 2020 at 4:20 pm #6987055
salvatoreM-13

Hey WPML Team

I use the Divi Theme on my website. The site was completely finished an translated, today I noticed, that the german content is not displaying anymore on Pages (Blog and CPTs are still working).

The strange thing is, when I open the translation Editor it only shows the RankMath custom fields. But nothing from the Page itself. Any suggestions what this could be?
I updated WPML to the latest version.

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/a-warning-about-taxonomy-sync/

September 11, 2020 at 6:19 pm #6996395

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please visit WPML>>String Translation, search for the strings of the pages having the issue and check the strings are showing for translation or not.

Please visit WPML>>Packages and it is showing String packages for the pages had this conflict. We can find the Package by the ID of the Page. Refer to the following documentation and attached image for more details.

https://wpml.org/documentation/support/string-package-translation/

Also please share with me the WordPress debug.log (not WPML debug information) for tracking the issue. Visit this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable WordPress Debug log, open your wp-config.php file of site root and look for define('WP_DEBUG', false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

September 12, 2020 at 10:52 am #6998721

salvatoreM-13

Hey Bigul,

Thanks for your reply.

The strings for the pages are showing on string translation, I also tested to add a translation on one string and it is successfully showing on the page.

Also the ID for the Page is showing under packages.

But on the page translation it's still not showing. (screenshots attached)

I have modified the wp-config file, but this gave me an error and the page was not accessible anymore (back & frontend). This is the section of the wp-config file that created the error:


/**
 * For developers: WordPress debugging mode.
 *
 * Change this to true to enable the display of notices during development.
 * It is strongly recommended that plugin and theme developers use WP_DEBUG
 * in their development environments.
 *
 * For information on other constants that can be used for debugging,
 * visit the Codex.
 *
 * @link https://codex.wordpress.org/Debugging_in_WordPress
 */
// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
  
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
  
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
/* That's all, stop editing! Happy blogging. */

/** Absolute path to the WordPress directory. */
if ( !defined('ABSPATH') )
	define('ABSPATH', dirname(__FILE__) . '/');

/** Sets up WordPress vars and included files. */
require_once(ABSPATH . 'wp-settings.php');


define( 'WP_MEMORY_LIMIT', '512M' );

Thanks and best regards

Salvatore

September 12, 2020 at 5:46 pm #6999817

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the feedback. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please refer to the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

September 14, 2020 at 6:47 pm #7012375

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the login information. Please check the attached images. All the Divi Builder Element strings of the Band page are registered for translation. But only one string is translated now. I am getting the expected result in the frontend when I translate a few of the strings of the Band page from the WPML>>String Translation panel. The browser console is showing a JavaScript error while translating the page using Classical Translation Editor.

So just to make sure, this issue is happened before upgrading to WPML 4.4 series am I correct? Do you have site backup before having this bug?

Please try the following steps after a full site backup and check is there any difference in the result.

1) Upgrade all the plugins to the latest version
2) Upgrade Divi theme to the latest version
3) Activate Classic Editor plugin - https://wordpress.org/plugins/classic-editor/
4) Clear all types of caches, if any
5) Open the Band page for edit in English
6) Make a minor change in the contents
7) Update the page
8) Open the German translation for edit in Classical Translation Editor

I have a request. Please upgrade the following configuration for the better performance of the site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

2) Increase the *MaxInputVars* of PHP settings to *5000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

September 15, 2020 at 12:30 pm #7018081

salvatoreM-13

Hey Bigul

Thanks for your suggestions. I've done all the steps and I'm now able to show up the divi fields in the translations after making changes to each page in english and saving it. After that, all the content appears in the translation settings. So far so good.

But now still all my translation is lost (the whole site was finished translating) and now every site, that used the divi builder, has lost the german translation. Do you have any idea why this happened?

I also increased WP Memory limit and MaxInputVars, thanks a lot for the tipp. 🙂

Best regards

Salvatore

September 15, 2020 at 5:44 pm #7020245

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the feedback. Please let me know the following to track this bug.

a) This error has happened before upgrading to WPML 4.4 series, am I correct?

b) Have you done any major changes in the sites other than WPML upgrading recently? Do you have site backup before having this bug?

c) On other sites also this bug is only happening with Pages?

--
Thanks!

Bigul

September 16, 2020 at 11:41 am #7026947

salvatoreM-13

Hi Bigul,

a) I don't know for sure when does the error happened. I noticed it later. I think it happened after upgrading to 4.4

b) I made some SEO optimizations with RankMath

c) It happened on every Page/Post using the Divi Builder. The other content that was created with Gutenberg Editor has not lost the translation.

I was able now to restore all translations from a backup, so the site is running again. 🙂

Thanks a lot Bigul.

Best regards

September 16, 2020 at 5:36 pm #7030075

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the feedback. So you are currently using the WPML 4.3.19 version on the restored site now, am I correct.

Please share with me the login credentials to access the site. It shows the following warning while login.

Unknown username. Check again or try your email address.

--
Thanks!

Bigul

September 19, 2020 at 8:15 pm #7051671

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the feedback. Just to make sure, are you still having the translation issues with Divi after upgrading to WPML 4.4.2?

I am still unable to access the backend now. So please share the credentials for further checking.

--
Thanks!

Bigul

September 24, 2020 at 5:41 pm #7093667

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Salvatore,

Thank you for the feedback. Happy to know you are getting the expected result while translated the pages.

Please note, I have opened a new ticket for the warning about the taxonomy sync issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. Also, it will help other users with similar problems find solutions when searching the forum. I will get back to you soon on the latest ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul