This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Hi, Amit here, I am the WPML Support Manager, please make sure you are using the latest WPML 4.3.15 before reporting an issue, thanks!

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Dražen Duvnjak 1 week, 1 day ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 23, 2020 at 1:07 pm #5977429

michaelD-28

Hi,

I'm trying to keep my wordpress admin to stick to the admin language defined in the user profile. My entire WP admin sticks in English like it's meant to but DIVI switches in the post language.

There are many threads concerning this issue, but they are a bit old. Most of the time they refer to WPML settings that don't exist anymore.

I tried disabling the string translations in the Divi settings. On the first load the admin Divi builder is in English but then reload in French.

Based on: https://wpml.org/compatibility/2019/10/update-on-divi-4-0-and-wpml-compatibility/ it seems that it was fixed in WPML 4.3.7.

Divi: 4.4.3
WPML: 4.3.12

Thanks

Michael

April 24, 2020 at 12:52 pm #5986651

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Michael,

Thank you for contacting WPML Support.

I checked this issue in our issue tracker and noticed it is something our compatibility team is still working at, unfortunately, I don't have any estimated time when it will be done as it is not something we as a supporter can estimate and also because the Divi team itself needs to cooperate with that. Hopefully, fix will be released soon.

For now, you can try next workaround

1 - Click on the Divi > Theme Options > Builder > Advanced
2 - Disable the "Enable The Latest Divi Builder Experience" option
3 - Click on the 'Save Changes' button

Info: https://wpml.org/errata/divi-builder-ui-labels-are-displayed-in-the-post-language-instead-of-the-admin-language/

Hope it helps, thank you for your understanding.

I will be marking this ticket as Escalated to Compatibility team and I will be updating you as soon as I have some new information.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way.

Regards,
Drazen

May 23, 2020 at 11:32 am #6200875

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

this issue is now solved with WPML 4.3.13.

Changelog: https://wpml.org/download/wpml-multilingual-cms/?section=changelog

Please update and let me know if you still have an issue.

Thanks, regards,
Drazen

May 23, 2020 at 12:29 pm #6200989

michaelD-28

Hi Dražen,

Even after updating, the admin language still follows the post language and not the one defined in the user profile. Are there any settings necessary to achieve this, aside from deactivating "Enable The Latest Divi Builder Experience" ?

I attached a screenshot to illustrate. The Divi builder is in French (Post Language) while everything else in English (Profile Language)

Thanks

Michael

May 23, 2020 at 2:29 pm #6201343

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the update.

Please allow me some time to try and test it with the latest version and check with our developers on this case.

In the meantime and in order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks,
Drazen

May 26, 2020 at 6:13 am #6215623

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for sharing and checking.

I am marking this ticket back as Escalated to Compatibility team, as it seems the issue was not fixed and it still appears in some scenarios.

Sorry for any inconvenience caused.

I will get back to you soon.

Thanks,
Drazen