Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by tonyD-4 6 months, 3 weeks ago.

Assigned support staff: Osama Mersal.

Author Posts
March 9, 2022 at 4:03 am #10745645

tonyD-4

Hi,

This page has a Divi video module where I am adding a vimeo link to it. The video works on English (Default) but the video does not work on Chinese version

hidden link

ezgif.com-gif-maker (3).gif
March 9, 2022 at 10:12 am #10747705

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for contacting WPML forums support. I'll be glad to help you today.

1) Could you please check the following steps?
1- Edit the page in English
2- Switch the language using the top admin bar
3- Check the video module on the translated page
4- Make sure it's configured correctly, and click on the update
5- Check if it works correctly on the front end

2) It's not related to the issue, but according to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

Add this to the top of wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

I hope this helps you. If you need further info, please let me know.

Best regards,
Osama

March 9, 2022 at 8:16 pm #10753787

tonyD-4

Hi,

When I tried to follow the step 2, the Divi builder didn't work for hidden link.

Then I ticked the option 'Auto sign-in and sign-out users from all domains' in side WordPress Dashboard > WPML > Languages > Language URL format. Then logged out from the English version and logged into the Chinese version hidden link and then tried to edit the page. That was successful. The Divi builder was loading fine. Looks like you need to login to a the website when you use different domain with WPML

The I followed from step 3 to 5. But the video is not working.

March 9, 2022 at 8:19 pm #10753793

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your update. I would need to take a closer look at your site. So I would need to request temporary access (WP-Admin and FTP)
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private, which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would need your permission to de-activate and re-activate Plugins and the Theme and to change configurations on the site if needed. This is also a reason the backup is critical.

✙ I also need your permission to take a local copy of your site to debug the issue without affecting your live site.

Thanks for your cooperation

Regards,
Osama

March 9, 2022 at 8:42 pm #10753851

tonyD-4

Hi,

I think I found the issue. This happens because of the hidden link.

I changed the language to be Chinese from the tool bar and disabled the script blocker for Vimeo. That solves the problem

But It should not happen even if it's enabled Because I have accept all the cookies on the site for some reason it does not work for other subdomains.

I don't think I could set up a dev site for you. But I can give you the permission to take a copy of it. Do you still need FTP logins or, do you have a solution for the above

Capture.JPG
March 9, 2022 at 8:49 pm #10753929

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I think you found a workaround to fix the Divi video module by disabling the script blocker for Vimeo in the Chinese language.

If you deactivated the script plugin, do you face the same issue?

Thanks,
Osama

March 9, 2022 at 9:39 pm #10754143

tonyD-4

Yes, that works. But I do not want to do that. It works as expected on English language but not the others. I would want to know why is that. Because Accepting cookies is important and I need to make sure all the three languages has the same policy.

March 9, 2022 at 9:47 pm #10754155

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

May I ask you to run the following tests to know what is causing the issue?

1) Language URL Format test:

Please go to WPML-> Languages, and select "Different languages in directories". After that, please clear your site's cache and delete the cookies from your browser and check if the issue persists.

2) Minimal installation test:

If the issue persists, please check if the issue persists in a minimal environment by following these steps:

1- Deactivate all the plugins except WPML CMS and the script blocker plugin.
2- Switch for a moment to a WordPress default theme like Twenty Twenty-one.

If the issue is gone, activate one by one to see which one is causing an interaction issue.

❌ Please backup your database before performing the above test ❌

Would you please let me know the result of these tests? These tests will help us understand if the issue is caused by the language URL format or a plugin conflict.

Thanks for your cooperation

Regards,
Osama

March 9, 2022 at 9:56 pm #10754165

tonyD-4

Hi,

It works with directory format

March 9, 2022 at 10:00 pm #10754173

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your update. Could you please share the dashboard login details to check it?

Thanks,
Osama

March 9, 2022 at 10:25 pm #10754319

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the access details. I've checked your site and set the "GDPR Cookie Consent (cookielawinfo)" post type along with the "Cookie Category (cookielawinfo-category)" taxonomy to be "Translatable - use translation if available or fallback to default language". (Kindly check this hidden link)

After that, I've checked the translated page, and the video worked correctly. (Kindly check this hidden link)

Would you please check it and let me know if it works at your end?

Thanks,
Osama

March 9, 2022 at 10:42 pm #10754365

tonyD-4

Thanks! That works.

Can you explain what was the reason for the issue?

March 9, 2022 at 10:45 pm #10754369

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

It's great to hear that it's working now. You might need to translate or duplicate the Cookie List and Cookie Categories because they are not translated, and I think that's what causes the issue.

Cookie-List: hidden link

Cookie Categories: hidden link

I hope this helps you. If you need further info, please let me know.

Best regards,
Osama

March 9, 2022 at 10:47 pm #10754371

tonyD-4

Can I do that via downingpoc.co.nz instead of login to the cn. version

March 9, 2022 at 10:49 pm #10754379

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Yes, you can do it from the main domain. I just copied the URLs while logged in to the subdomain.

Have a good day!

Regards,
Osama