This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 23 replies, has 2 voices.

Last updated by Tom 2 weeks, 6 days ago.

Assigned support staff: Andreas W..

Author Posts
September 16, 2019 at 12:45 pm #4580233

Tom

hi carlos,

when we switch the language, it does not link to the corresponding secondary language pages but always back to the home page of the language you have selected.

we have replicated the site on a new URL and have found the culprit who is BRIDGE CORE plugin. the link that you see has bridge core plugin deactivated.

how to get that fixed? thanks in advance.

br,
tom

September 16, 2019 at 8:50 pm #4584099

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could you please install the Bridge Theme and its plugin on the following test site and try to recreate the issue. If the issue also appears on a new WordPress install than we will hnadle this s comaptiblity issue and I will escalate to oru compatiblity team in order to find a solution.

One Click Login: hidden link

Leave me a short notification once theme and plugin are installed.

Kind regards
Andreas

September 17, 2019 at 12:36 pm #4588459

Tom

hi andreas,

thanks for your reply. we have installed the theme and all the bridge plugins but we cannot replicate the issue. can you just log in to our demo site to fix the issue?

br
tom

September 17, 2019 at 4:13 pm #4590073

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

September 18, 2019 at 10:00 pm #4600053

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have enabled all the plugins and tested the WPML language switcher on almost all pages I think and I can not spot the issue.

Could you please provide me a link or a screenshot of the sections or pages that are causing issues?

Kind regards
Andreas

September 19, 2019 at 4:20 pm #4607323

Tom

hi andreas,

thanks for your quick response.

it would have been better if i could reply to carlos earlier. i would have gotten this fixed by then!! shame on me!!! the client has delayed the project and i was too busy with other projects so...

i dont think i have explained well enough to make you understand! the issue has always been there. say now you are on the our people english page and you click on say traditional chinese language switcher, you are supposed to see our people traditional chinese page but instead you can see the home traditional chinese page!! is that a problem???

so now please try and deactivate all the plugins including bridge core. the issue will disappear. then reactivate only the bridge core plugin, the issue will resurface. any idea?

br,
tom

September 20, 2019 at 3:45 am #4609595

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

The site has currently all plugins enabled.

1) I went to the English "Our people" page.
2) I checked the links for the language switcher (Mouse over and checkign the left bottom corner of the browser window) - The links are correct.
3) I clicked the WPML Language Switcher of the "Our people" in order to open the pages and been redirected respectively to:
- /zh-hant/我們的人員/
- /zh-hans/我们的人员/

Everything is working as expected from my view. I also received the same result when not beeing logged in to the site.

Did I miss something here? I checked quiet all the areas of the website twice now, I did not experience and false redirect so far.

Maybe you could provide a video? Also please try different devices and browser.

Kind regards
Andreas

September 20, 2019 at 9:49 am #4611107

Tom

hi andreas,

thanks for your reply.

i guess you were using either edge, IE or safari. if you use firefox and chrome (even for incognito), you will spot the issue which is carlos did too.

any idea?

br,
tom

September 20, 2019 at 3:56 pm #4613423

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

This seems to be a random issue. It is the third time that I revised the website and now, indeed I can see wrong redirects on Google Chrome, Chrome Incognito Modus and on Edge. (Our people links to Homepage)

I then deactivated everzthing and tested with the WPML plugins and WPBakery only and the issue was gone. Then I reactivated Bridge Core. First the Our people page linked back to the homepage on the first site load, but after loading the pages a second it the redirect was correct. But still the "Contact Us" page redirects here to "Our people".

I am not sure what is causing the issue and I would like you to install the Bridge theme and Brodge Core (both at their latest version) on the following test site, in order to test the bahvior on a new WordPress install:

One Click Login: hidden link

If the same issue appears here we are having a compatilbity issue between theme and WPML. The weird thing is only that the issue is somehow randomly.

Are you using any server side caching? If so, could you test if the issue disappears if the server cache is disabled? I can also offer to send information for migrating your site to our test-server for more debugging, burt first let us test, if the issue also appears on a new WordPress install.

Leave me a short notification once the Bridge theme and Bridge Core are installed. In case you find the time to recreate the issue in a simple manner, it would be very helpful and save time.

Kind regards
Andreas

September 21, 2019 at 9:30 am #4615693

Tom

hi andreas,

thanks for your reply.

as mentioned in my last email, you asked me to replicate the issue on the previous test site but i could not.

i have installed bridge theme and all bridge required plugins including bridge core in the test site as instructed.

thanks in advance.

br,
tom

September 24, 2019 at 12:47 am #4626953

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was sadly not able to recreate the issue on the new install. Everything works here as expected.

Enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results. In order for WordPress to gather the errors please go to your front page and switch between language until the false redirect appears.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

I suppose that there are errors as on your site the issue seemed to be related to the Bridge CorePlugin.

If there will not be any errors the issue is most likely server related. I would also suggest to reach out to your hosting company and ask them to check the server error.log for false redirects, and in order to verify the server´s config.

We further can offer to migrate your website to a test server, to see if we experience the same issue there.

Let me know about the outcome.

Kind regards
Andreas

September 24, 2019 at 3:30 pm #4632857

Tom

hi andreas,

thanks for your reply.

no debug.log has been created. we added one on our own but nothing has been created in the file.

we have accessed /var/log/apache2/error.log.1 and have found some errors related to bkic2 as follows. not sure if they have anything to do with the issue.

[Tue Sep 24 00:39:17.702463 2019] [access_compat:error] [pid 27599] [client 179.6.213.150:24142] AH01797: client denied by server configuration: /var/www/projects/public_html/favicon.ico, referer: hidden link
[Tue Sep 24 00:39:39.465107 2019] [access_compat:error] [pid 27959] [client 179.6.213.150:24246] AH01797: client denied by server configuration: /var/www/projects/public_html/favicon.ico, referer: hidden link
[Tue Sep 24 00:40:40.402696 2019] [access_compat:error] [pid 27599] [client 179.6.213.150:24938] AH01797: client denied by server configuration: /var/www/projects/public_html/favicon.ico, referer: hidden link

we have offered to import the entire site to the test site but you had no response. we tried by using wp all migration but it didnt let us. this is way easier than duplicator. can you make sure we can use wp all migration? then we will import the entire site there for testing.

br,
tom

September 24, 2019 at 7:24 pm #4633885

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have sent you a private message with access information for migrating your website to our test server for further investigation.

Please leave me a short notification once the site is migrated.

Kind regards
Andreas

September 25, 2019 at 10:36 am #4637945

Tom

hi andreas,

thanks for your help.

the migration is complete.

look forward to hearing from you soon. thanks a lot.

br,
tom

September 25, 2019 at 3:21 pm #4640429

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

While debugging the issue on our test server I realized that the issue disappears when I change to another theme. In this case, I used the default theme Twenty Nineteen.

As mentioned earlier I also tried to recreate the issue using the same version of Bridge Theme and Bridge Core on a new WordPress install but the issue does not occur here.

The only logical explanation so far would be that we are not dealing with the identical theme or different settings. Did you make any custom coding changes to the theme on your live site?

In case you changed any code please provide me more details. The issue is clearly related to your currently used theme.

Could you please have a look at the following site and revise the pages, menu, and setting. Please try to recreate the issue.

One-Click Login: hidden link

Kind regards
Andreas