This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Andreas W. 8 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
January 23, 2019 at 11:00 pm #3122671

viktorsL

I am trying to: use the link to woocommerce checkout page with ?add-to-cart atribute with different languages

Link to a page where the issue can be seen: hidden link

I expected to see: when using different language to see the checkout page in that language.

Instead, I got: only the default language checkout page

hidden link - works but it does not add an item to cart!

January 24, 2019 at 12:01 am #3122759

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

Could you please verify the status of your translations at WooCommerce -> WooCommerce Multilingual -> Status.

Please make sure that also all the store URL´s are translated correctly without any duplicated names.

Further, at the bottom right of this screen you will find a option for "troubleshooting". Please select it and then sync any of your store content.

I hope this troubleshoot could solve your issue. Otherwise please provide me access to your site so that I can take a closer look at the issue.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

January 24, 2019 at 7:00 pm #3126692

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I connected to your page and checked the translations for your English Checkout page. I realized that you are translating manually using the native WordPress Editor.

I changed the setting got "How to translate posts and pages" at WPML -> Settings.

then I realized that there is one strign entry that refers to the page builder element that includes the button URL for the Price. Simply replace the URL for the button on the English translation with the Checkout page URL: hidden link

This should solve the issue.

On the other hand, now new page translation will open inside the WPML Translation Editor and we do recommend to use this method for page builder content like Divi to maintain the compatibility between content and WPML.

https://wpml.org/documentation/theme-compatibility/divi-builder/

I would further advise you to consider changing the URL site structure at WPML -> Languages. Maybe show languages in directory would be a good option here. Please make sure to make a site and database backup before taking any changes.

Kind regards
Andreas

January 25, 2019 at 5:45 am #3127929

viktorsL

As I wrote in my first massage hidden link works, but does not add an item to cart! I neeed it to ad an item to cart! Like this link => hidden link The only thing I want so it would go to translated page aswell.

January 25, 2019 at 6:21 am #3127964

viktorsL

I can not change the structure, plugin says there is some problems with that => Different languages in directories ((hidden link - Latviešu, hidden link - English))
It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses hidden link it gets:
The expected value is:
<!--hidden link;

I performed all the changes in the guide, that did not help

January 25, 2019 at 6:53 am #3127998

viktorsL

"then I realized that there is one strign entry that refers to the page builder element that includes the button URL for the Price. Simply replace the URL for the button on the English translation with the Checkout page URL: hidden link"

THAT REALLY SOLVED THE ISSUE. Thank you.

But the problem with website structure still exists. My server is wpengine and we did all the steps that were in the gauide and still can not use difference structure

January 25, 2019 at 6:56 am #3128000

viktorsL

Now the translated text does not appear on my landing. It is all in one language again.

January 25, 2019 at 3:55 pm #3129701

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

I was checking your website and I realized that your WP_Memory limit does not fulfill the minimum requirements to run WPML.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please also change the setting for maxInputVars inside of your php.ini files. This file is located on your server inside the folder for PHP 7.2.13. You are currently using a value of 1000. I would advise you to change this value to at least 3000.

If you are having problems to locate and/or edit the file please contact your hosting provider and ask for assistance. Once those settings are changed I will be able to have alook at your site again.

Kind regards
Andreas

January 25, 2019 at 6:51 pm #3130262

viktorsL

We did the changes, could you check again please? thank you

January 25, 2019 at 10:00 pm #3130623

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for the notification.

Sadly I was not able to find a workaround to the issue so far. Similar issues have been reported to our compatibility team when using the Divi theme and we are working on a solution for those issues.

When it comes to the button URL I can see that all the URLs are available on the Translation Editor, but only one is missing. I tried to add it using a custom XML configuration for the themes language file which can be added at WPML -> Settings -> Custom XML Config.

https://wpml.org/documentation/support/language-configuration-files/

Sadly the attempts were not successful. Then I recognized an entry on the Translation Editor that is titled with divi/placeholder. This string contains all the page content of the original page and somehow overwrites your translation. Our compatibility team is working on a solution towards this issue which will be provided as soon as possible on the next WPML update.

We are very sorry about any inconveniences and I will keep you updated about the process.

Please let me know if do have any questions.

Kind regards
Andreas

January 26, 2019 at 3:13 pm #3131605

viktorsL

I still have problem with links to checkout page. The problem is that I pass an arguments with the link to add an item to the cart : hidden link
The argument is ?add-to-cart=387
How can I make a link that will have two arguments that will work. I mean hidden link and ?add-to-cart=387
Thank you

January 28, 2019 at 1:11 pm #3135594

viktorsL

I figured it out myself. But it took a while. So to pass two URL parameters you have to use "&" sign.
In my case it was /?lang=en&?add-to-cart=387 which works great.
But /?add-to-cart=387&?lang=en does not work.

January 28, 2019 at 10:02 pm #3137606

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I am glad to hear that you found a workaround. I would kindly like to advise you to stay with the default URL structure when using WPML and WooCommerce. As I can see now the URL for the English Checkout page is hidden link which is default.

As suggested earlier another solution for you might be to use language by directories:

Example:
hidden link

Please have a look into the following documentation to enable language in directories for your WordPress site:

https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

Please let me know if you need any further assistance about the issue. If the issue is solved for now please do not forget to mark this ticket as solved.

Kind regards
Andreas

February 1, 2019 at 11:53 pm #3153569
viktorsL

Hello!
Now I am having an issue with translations, after I edited original page, which was landing page (I deleted wpml language flag shortcode) the translation editor showed that I need to update my translations, after I did that, my translations stoped working. Everything now is in default language even though translation editor shows that everything is translated. You can check it on hidden link
Thank you!

New threads created by Andreas W. and linked to this one are listed below:

https://wpml.org/forums/topic/after-deleting-wpml-language-flag-shortcode-translations-stopped-working/

February 4, 2019 at 2:21 pm #3158047

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I have opened a new ticket regards the latest problem on your site. This procedure will help other customers to find an answer for their similar issue on our forum.

Please make sure to mark this ticket as solved. I will answer you on the the new thread very soon.

Kind regards
Andreas