Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 3 years, 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
November 18, 2018 at 3:23 pm #2917509



I placed a language switcher on topmenu but does not show up.
If I add the suffix "en" after the url then I land t a 404 page with the language switcher appeared on topmenu.

Here is the web site hidden link

Please advice

November 19, 2018 at 7:00 am #2918428

Mihai Apetrei

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, I removed your credentials from your post as they were public so we don't want that.

I can see the language switcher as the last item in your top menu (I am attaching a screenshot, too). Whenever you click that, you will see that the last element in the menu changes (when you are on english, it will show you italian and when you are on italian, it will show you english).

Also, WPML is currently set up on your site to use language parameters so that's why adding "en" at the end of the link doesn't work. You would need to add "/?lang=it" or "/?lang=en" in order to do what you want.

However, you can change this setting in WPML > Languages > "Language URL format" section > "Different languages in directories" > click "Save" (I am attaching a screenshot, too).

You can also update the way the language switcher look in your menu here: WPML > Languages > "Menu language switcher" section > click the pencil icon under the "Actions" column and then you can decide if you want the switcher to show language flags, too and other things. (I am attaching a screenshot for this, too).

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,

Screen Shot 2018-11-19 at 08.56.09.png
Screen Shot 2018-11-19 at 09.00.23.png