This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by L 1 month, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 7, 2020 at 1:07 pm #5857619



I'm looking at wp-content/uploads/cache/wpml/twig

I saw a lot of folders and files there. There also was a folder called '77'. I looked at that 77 folder because of this topic:

That user also names the 77 folder.

I then deleted the cache.

Then the cache came back, which is OK.

But the folder '77' wasn't there anymore.

So... was this '77' not intended to be there?

Or does WPML create random folders of cache?

April 8, 2020 at 6:12 pm #5868939


Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

It is an expected result. WPML will add caches because it is using twig files, especially for the language switcher. The caches folder will be random ones. We can clear it by clicking *Clear the cache in WPML* option of Clean up section from WPML>>Support>>Troubleshooting page. But the caches files will be created again when we access the configuration pages and pages & posts with the language switcher.

We can also disable the caches for the WPML language switcher by clicking *Disable cache for language switcher templates* button of WPML>>Support>>Troubleshooting>>Advanced settings.

Please check the attached images for more details and let me know your feedback.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:



April 14, 2020 at 3:13 pm #5905735