This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 19, 2019 at 7:08 am #4048663

nihatI

When I give a translation job from Turkish to German. It turns out to be empty for interpreters.

June 19, 2019 at 7:44 am #4049043

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I kindly ask you to visit this link where you will find our official documentation on how to translate a site using Elementor: https://wpml.org/documentation/plugins-compatibility/elementor/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

June 19, 2019 at 10:00 am #4050441

nihatI

Hello,

I added memory limit code on wp-config.php file but it The problem still exists.

It works when I order an English-German translation. But German does not work from Turkish

Translation fields do not come. Please review it without writing template message.

June 19, 2019 at 10:56 am #4050931

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your message.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

June 19, 2019 at 8:18 pm #4054523

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I took a look at the site and it seems that some issue happened during the creation of this pages. I created a test page in Turkish (hidden link) and as you can see I was able to 'translate' them to all languages, which means that the translation is working properly for newly created pages.

In this case I recommend you to re-create the pages and translate them again.

Please let me know if you need further assistance.
Regards,
Carlos

June 19, 2019 at 8:41 pm #4054615

nihatI

I can't delete existing pages and redo them.
The problem still continues.

Why this issue could not be resolved

June 19, 2019 at 8:43 pm #4054621

nihatI

I can easily translate from English to German. But I can't translate from Turkish to German.

June 19, 2019 at 9:11 pm #4054783

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I don't have enough information to tell you what was the cause of the issue as it is not happening for new pages. I just can tell you for sure that is not happening for new pages, which means that whatever happened is not happening at this moment.

If you desire we can migrate the site to one of our test servers and make further tests to try to find what was the cause of the problem in the first place.

Please let me know and I will create the test server.
Looking forward to your message.
Regards,
Carlos