This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Dokan multivendor plugin links broken

Solution: Updating WooCommerce to the latest version and going to Settings -> Permalinks and saving the permalinks once solved the issue

0% of people find this useful.

This topic contains 9 replies, has 3 voices.

Last updated by andreaS-28 11 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 24, 2018 at 10:17 am

germanG-3

I am trying to:
Use WPML with dokan multivendor plugin. Otherwise it looks ok, but dokan dashboard links are broken, i.e. i checked the code and dokan generates this link fermania.com/dashboard/products but i think wpml somehow transaltes it to fermania.com/dashboard.

Link to a page where the issue can be seen:
hidden link

I expected to see:
dashboard links working

Instead, I got:
dashboard links "stripped" to hidden link

I tried contacting dokan support but they refuse to support me with WPML integration. I have a programming background but not in php, but i'm willing to do some code changes if necessary. My idea is tho somehow skip url transalltion for a given array of patterns or urls.
Please help.

October 25, 2018 at 11:36 am #2849567

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

We recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Further, it seems your ftp details is not working, could you please check and update it? You can edit your previous private reply to send the updated details.

Look forward to your reply.

Thanks

October 25, 2018 at 7:49 pm #2851018

germanG-3

Hi, installed all latest versions, didn't help unfortunately

October 26, 2018 at 12:27 pm #2852958

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems that still your ftp details is not working, could you please check and update it? You can edit your previous private reply to send the updated details.

Thanks

October 29, 2018 at 3:21 pm #2858593

germanG-3

Hi, sorry, what left overlooked is the fact that ftp connection is using ssh key. Do you want me to send ssh key to you? Sorry I didn't find a way to edit my message with private details.

October 30, 2018 at 8:05 am #2860745

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Instead of using ssh, it would be more easy to move forward if you can send me wp-content and database backup, you can zip these files using google drive and share the links with me.

I have enabled the private reply so you can send these details in the next reply.

Look forward to your reply.

Thanks

November 3, 2018 at 9:31 pm
November 5, 2018 at 10:31 am #2876451

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I installed your site and when updating WooCommerce to the latest version it's working properly on my end, so could you please update WooCommerce to the latest versions and let me know if this helps?

Also, after updating go to Settings -> Permalinks and save the permalinks once.

Look forward to your reply.

Thanks

November 8, 2018 at 11:17 am #2889150

germanG-3

My issue is resolved now. Thank you!

September 21, 2019 at 5:16 pm #4616579

andreaS-28

@shekhar Bhandari this still happens with WPML and WooCommerce latest versions, can you please advise? As soon as I disable the WPML main plugin, all links start working again.

September 22, 2019 at 12:02 pm #4618373

andreaS-28

Apparently, this is caused by the function "fix_fallback_links" inside the "WPML_Fix_Links_In_Display_As_Translated_Content" class, which erroneously replaces permalinks on the dokan dashboard.