We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andrés 4 years, 4 months ago.

Assigned support staff: Andrés.

Author Posts
July 3, 2015 at 8:42 am #651932

franckj

Hello,
I saw many topics about this problem and also this one https://wpml.org/faq/server-setting-for-languages-in-different-domains/ but I can't make it work.

Wordpress : 4.2.2
WPML : 3.2.2
Theme : X theme -> 4.0.4

I have 3 domains
1) French -> hidden link
2) English -> hidden link
3) Russian -> hidden link

I want to have for each language one domain.
My server configuration's Nginx(offloading SSL) -> Nginx Backend -> WordPress
My DNS configuration is good, each domain map to the same wordpress installation and they are hosting in the same server.
Now, when I'm going to WPML -> Languages -> URL Language Format to define my domain and check the box validate when recording I get every time this error ( Error: data not saved ), When I uncheck the box and do it again I have no error, but when I go to the English page for exemple, it's not redirecting to hidden link but it still leave me on the same page(the default hidden link).
I tried with full HTTP and without backend server and it's stil the same.
Each language per directory working fine.But I want per domains.
I have no JS errors in the debugging.
I tried with no plugin, only WPML and stil the same.
If you need more informations I stay tuned.
Thanks in advance

July 3, 2015 at 11:11 am #652103

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Franck,

Welcome to WPML support,

1. Let me refer you to this thread where you can find some initial tips about setting Nginx server for WPML.
https://wpml.org/forums/topic/want-to-make-subdomain-for-any-language-on-nginx-server/

2. When using different domains for WPML its very important that all domains point to the very same WP installation directory - and that those domains are not redirecting.

# To test this:
Go to the index.php located in the WP root folder and add at the very top:

<?php exit( $_SERVER['HTTP_HOST'] ); ?>

and call your different domains.
Do you see always the domain name and no redirection occurs?

# mod_rewrite
Check with your hosting service that your Nginx server ( ngix.config ) can be rewritable.

#server_name
As you are using Nginx there is server directive "server_name ":

server_name <em><u>hidden link</u></em>
server_name <em><u>hidden link</u></em>
server_name <em><u>hidden link</u></em>

Please refer next link as well:
hidden link

3. Take on consideration this comment as well about resolving to no www domains:
https://wpml.org/forums/topic/nginx-different-languages-in-directories-not-working/#post-372594

I hope this information point you in the right direction.
Andrés

The topic ‘[Closed] domain per language don't work nginx’ is closed to new replies.