This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Domain per language is not validating, DNS seems to be correct.

In the browser's debugging tool it is possible to see the following for one of the domains.

no-referrer-when-downgrade

Solution:

Please make sure that all of your site's domains have a valid SSL certification.

Relevant Documentation:

https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Referrer-Policy

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Anne Jan 1 week, 6 days ago.

Assigned support staff: Itamar.

Author Posts
October 3, 2019 at 4:49 am #4684667

Anne Jan

Hi,

I have two domains .com (primary domain) and .nl. When i change language from English to Dutch i want the domain to change to .nl.

I have been trying to follow the guide :
https://wpml.org/2016/04/use-wpml-different-domains-per-language/
WP_DEBUG and debug.log doesnt give me much to go on.

But i dont get it because when i check the "different domain per language" i get "not valid".
I dont give me more to go on why it is not valid.

We run the website without www.
We tested it on a dev.domain.com and the validation worked.

When I visit domain.nl now you see the domain.com content.
So the DNS seems to work.

When I save it without validation and check it, the .com is redirecting me to the .nl when I try to translate a page on the .com via de wp-admin. But it first gives me a not safe notification, but I get that, this is a SSL thing.

But after that, it redirects me to the .com homepage instead of the admin.

The link to my site is: fullfact.com and fullfact.nl

Image DNS fullfact.nl: hidden link
Image DNS fullfact.com: hidden link

I like to get the .nl working and connected to the .com asap.
Thanks in advance.

October 3, 2019 at 1:14 pm #4687917

Anne Jan

Love to hear from you. thanks.

October 3, 2019 at 7:23 pm #4691027

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see that hidden link is redirecting to hidden link.

I suspect that this issue does happen because of the SSL certificate that seems to be missing for hidden link. I say it because when I check with the browsers developers tool the redirection that is happening, I see that there is a 302 Found with the Referrer Policy of no-referrer-when-downgrade. Please see the attached screenshot no-referrer-when-downgrade.jpg. At the following link, I've found a good explanation about no-referrer-when-downgrade.
hidden link
It declares this:

This is the default behavior if no policy is specified, or if the provided value is invalid. The origin, path, and query string of the URL are sent as a referrer when the protocol security level stays the same (HTTP→HTTP, HTTPS→HTTPS) or improves (HTTP→HTTPS), but isn't sent to less secure destinations (HTTPS→HTTP).

Could you please also provide an SSL certification for fullfact.nl and see if it solves the issue?

Thanks,
Itamar.

October 3, 2019 at 8:00 pm #4691171

Anne Jan

Thanks Itamar. We are working on that.

But why is dev.fullfact.nl working then?
This is the same domain.

I hope tomorrow the SSL is working and I can let you know if this fixes something.

October 4, 2019 at 6:49 am #4693123

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Thanks, I'll wait for your reply.

In any case, from my experience, those issues mostly come from misconfigurations of the server and not because of some issues with WPML.

By the way, did you remember to re-save the permalinks after saving the Language URL format settings?

Also, you are using the W3 Total Cache plugin, and this might be a cache issue. Please clear all the cache on your site and deactivate the W3TC plugin to see if this helps. When using this plugin with WPML, it is important that follow our documentation here.
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

In addition, but not necessarily related to this issue, please correct the following.

1. Update WordPress to its latest version.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

2. Update WPML and its add-ons to their latest versions.

3. By looking at the debug info that you have attached, I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

October 4, 2019 at 5:50 pm #4698011

Anne Jan

I checked everything you mentioned.
Disabled cache, re-save permalinks.
It's still isn't working.

The SSL should work now.
But I still see the no-referrer-when-downgrade header response.

So I don't know anymore what could be the issue.
How can I properly debug the validation process from WPML?
Why is it saying 'Not Valid'. What kind of checks is it doing?
I think there we can find more info on what it wrong.

Thanks.

I understand the directions of your feedback, but dev.fullfact.nl is working. So to me it's strange that fullfact.nl isn't working. Isn't that something we can look into?

October 5, 2019 at 7:52 pm #4701007

Anne Jan

Love to get a reply. Thanks in advance.

October 6, 2019 at 3:35 pm #4702675

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, and thanks for trying my suggestions.

It is not clear to me.
Have you also update WordPress and WPML + add-ons to their latest versions?

It is known to us that in some cases, when checking the 'Validate on save' option, you get the 'Not Valid' message when actually everything is OK.
Can you please uncheck the 'Validate on save' option and see if it helps in this case?

You wrote that the SSL should work now, but when I check hidden link for the first time on another browser (I've tried FireFox and Edge), I can see that it has no SSL certification. Please see the attached screenshot.
Can you please make sure that both hidden link and hidden link have a valid SSL certification?

Thanks,
Itamar.

October 9, 2019 at 8:29 pm #4725497

Anne Jan

My issue is resolved now. Its was the multi domain SSL that need to be arranged.

Thank you!

it would be great if WPL can make it a LOT easier to debug this instead of 'Not Valid'.