Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 3 voices.

Last updated by andoni larrañaga 1 year, 6 months ago.

Assigned support staff: Bigul.

Author Posts
January 22, 2019 at 3:39 pm #3117284

andoni larrañaga

Hi;

I am trying to configure "Domain per language" option with this domains:
- hidden link (spanish - main language)
- hidden link
- hidden link

When I configure this option all is correctly validated and seems ok, but not working.

All domains are well configured in the hosting.
I try with default WP .htaccess file.

When I try to access any domain, it redirects to base domain.

If I try for example this url: hidden link it shows spanish posts, not french.
All content is translated as you can seen here: hidden link (now "domain per language" option is disabled).

Thanks!

January 23, 2019 at 3:14 am #3118863

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I can see that on your site silnatur.com currently different directories is enabled. So could you please let me know if the different domain is activated correctly? Would you mind providing me login details so I can quickly check your settings?

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

January 23, 2019 at 11:25 am #3120289

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems you have installed the main site in a subfolder as a reason the issue is happening, could you please install the site in the root directory and let me know if this helps?
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Look forward to your reply.

Thanks

January 23, 2019 at 11:40 am #3120335

andoni larrañaga

This site is installed in the root directory.

I don't understand your response...

If you are saying that we have configured to work on sub-folders in WPML, is because is not working...

Thanks for your support!

January 24, 2019 at 3:37 am #3123397

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Currently, when trying to set up different domains per language you can see that the default language URL is hidden link which somehow indicates that the site must be installed in /es/ directory, are you aware of this? Can you check if the site is installed on /es/ directory instead of root one?

Look forward to your reply.

Thanks

January 24, 2019 at 11:43 am #3124803

andoni larrañaga

Hi Shekar;

Now, we have activated in WPML this configuration: "Different languages in directories" and inside this, "Use directory for default language" option checked.

You must uncheck this option before activate the option: "A different domain per language".

As you see in the attached image, the urls are ok, but then navigation not works.

Thanks for your help.

January 25, 2019 at 3:45 am #3127778

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the info.

I activated the domains per language but it seems that the secondary domains are redirected to default language domains as a reason I couldn't test the issue forward, would you mind disabling this redirect?
hidden link is redirecting to hidden link as so on.

Look forward to your reply.

Thanks

January 25, 2019 at 9:55 am #3128361

andoni larrañaga

Hi;

We don't have any redirect enable. This redirect only appears when we activate WPML option "A different domain per language".

You can test that there isn't any redirect is you use the option "Different languages in directories":
- hidden link
- hidden link

So, this redirection is caused by WPML.

I hope this help you.

Thanks!

January 25, 2019 at 12:11 pm #3128837

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, we recently released new versions of WPML plugins with fixes and improvements so could you please update the plugin to the latest version and let me know if this helps?

NOTE:

+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

Further, If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Look forward to your reply.

Thanks

January 25, 2019 at 1:15 pm #3129054

andoni larrañaga

Hi Shekhar;

I update WPML to the latest version but still occurs the redirection on "A different domain per language" option.

Another thing to check?

Thanks!

January 28, 2019 at 2:17 pm #3135982

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Please share with me the WordPress debug.log(not WPML debug information) for more details. Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Also please check you are getting any error in the server(Apache) error log.

--
Thanks!

Bigul

January 28, 2019 at 3:08 pm #3136146

andoni larrañaga

Hi Bigul;

WP logs are activated but no error is registered there.

I looked at Apache logs on Plesk Panel but there is not any error.

Thanks!

January 29, 2019 at 12:55 pm #3139807

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Switch the language URL format to *A different domain per language* and save the changes

2) Visit Settings>>Permalinks, then resave the settings

3) Go to WPML>>Support page

4) Click on Troubleshooting link (blue link in the middle of the page)

5) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

--
Thanks!

Bigul

February 1, 2019 at 4:15 pm #3152380

andoni larrañaga

Hi;
Finally we solved the problem with a curious solution: there was set in the Plesk panel for all domains www preference.
We set this preference to not-www and solved the problem.
Thanks for your support!
My issue is resolved now. Thank you!