This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Andreas W. 1 month, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
August 5, 2019 at 11:37 am

Marzia

Hello, I added new language (netherland) and asked the server manager to point the new domain siampl.nl to same server (A record at 95.174.18.41). in Wpml settings the language format is a domain for each language, I set siampl.nl but it does not validiting it.
if a try visiting the url hidden link
I see plesk default page.
Since I am not the one managing the web server (I had to ask of doing so) I wondering if maybe they might have not set the http server as explained in this your tutorial.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/
I upload image of wpml format language settings, also siampl.com is not considered valid, I don't know why, since it's working perfectly.
Thank you for help!
Sorry; I could not install duplicator package

August 5, 2019 at 5:48 pm #4342349

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

The provided link to our documentation is in fact the correct way to configure the server in order to use language in different domains.

I also see that the homepage hidden link us actually available, while the Dutch translation seems not to exists so far. As one works and the other not it seems the issue is maybe related to the URL server config.

I checked the URL hidden link with MXToolkit and you can see the result on the screenshot. Please provide this information to your host provider or server technician in order to have a look into the issue and let me know if it was able to be solved on server side.

hidden link

Also I see that your plugins are not updated. Please make sure top have all WPML Plugins and third plugins up-to-date and verify if this solved the issue.

In case the issue will not be solved please have alook at the following article and let me know if the suggestion in regards to the parked domain setting, solved the problem:

https://wpml.org/forums/topic/the-different-domain-per-language-comes-up-as-not-valid/

Kind regards
Andreas

August 8, 2019 at 5:45 pm #4365211

Marzia

Hello Andreas,
thank you, They worked on the server and I think is "partly" solved. I can visualize website in dutch, but I stiil cannot validating urls but as long as they work let's leave it as they are.

I have a second problem, which maybe is related: I need to hide the language because the website translation is still in progress: I hid it in WPML > Languages, and in my user profile I set it as visible. I see "Nederlands" in the language switcher but when It try to select it, it i being redirect to the italian website (main language).
This does not happen of course when the language is public.
So Basically I'm not able to carry on my translation without the language being public.

Now language is not visible, please login in, have check inside and hide it ,so you can test the behaviour.
Thanks for help!

August 8, 2019 at 11:05 pm #4366227

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

Please test if the issue persist if you change to a default theme like Twenty Seventeen.

Also, please go to Plugins -> Add new -> Commercial and update the WPML plugins. If this will not solve the issue and the issue is not theme related we might take further steps, by migrating your site to our test server.

I will be sending a private message with acces to our test server in order to migrate your website for further testing.

Kind regards
Andreas

August 8, 2019 at 11:14 pm
August 8, 2019 at 11:16 pm #4366237

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have just left you a private message with access to our test server on this ticket. Make sure to follow the instructions and leave me a short notification once the migration is complete.

I will continue debugging the site without affecting your live site and our developers will take care about the issue, if necessary.

Kind regards
Andreas

August 9, 2019 at 12:50 pm #4370365

Marzia

I tried, but it says the url is not correct....

August 9, 2019 at 11:31 pm #4373213

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am very sorry about the inconvenience. In fact the information is correct but there seems to be an issue with the server.

I will have to follow up about this lately on monday as for some reason I am not able to add a domain to the server.

I hope for your understanding and will contact you as soon as possible.

Kind regards
Andreas

August 12, 2019 at 3:09 pm
August 12, 2019 at 3:11 pm #4381819

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

I have create a new access to our test server and I would like to ask you to complete the migration progress. You will find the details in the private box right above this message.

Please leave me a short notification once the site is ready for testing.

Kind regards
Andreas

August 13, 2019 at 9:46 am #4386765

Marzia

Hello Andreas, I'm sorry but due to the fact the I'm not in the office now (I'm actually on holiday in another place) I'm not able to transfer the site using hot spot, apart the fact t will take ages (probably 2 days) and exhaust completely my data traffic.
Aren't you able to fix the issue directly on site? Any workaround to public the website and make this this visible only to certain ips?
Sorry for that. Thank you

August 13, 2019 at 4:03 pm #4389381

Marzia

If I publish the language, I can try hiding my flag with css and make it visible opnly to admins.
Next I need to prevent indexing the dutch language, is it possible to do that? thanks!

August 13, 2019 at 5:10 pm #4390055

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I totally understand your concerns. I migrated your site to our test server and escalated the issue to our developers.

In fact, I was also able to recreate the issue on a new installation. The issue is therefore not server related and will need to be fixed inside WPML Core. As soon I received feedbacl and a proper workaround I will be in contact. The final solution should be provided within the next update for WPML CMS Multilingual.

Thank you very much for your patience.

Kind regards
Andreas

August 14, 2019 at 2:11 pm #4395799

Marzia

Hello Andreas, thank you for doing the migration in my behalf.
How long this issue will take to be fixed and be available in the next release? My client is has urgency to have the dutch website done. Thank you!

August 19, 2019 at 3:22 pm #4417099

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience while we been looking into the issue.

Here is what we did:

- Login on the default language (e.g. hidden link).
- Make sure that "Auto sign-in and sign-out users from all domains" option is checked at
WPML -> Languages -> Site URL structre
- Go to the admin area of the hidden language domain (e.g. hidden link)
- It will redirect to the login page of the default language. Login again.
- Now access the hidden language domain

It will work now with the language switcher or by going to the Dutch pages directly from the Backend.

Let me know if you need any further assistance.

Kind regards
Andreas