This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by George Botsev 3 years, 7 months ago.

Assigned support staff: George Botsev.

Author Posts
July 14, 2015 at 7:35 am #658564

Bryan

I am trying to:
create or list a post using the wordpress official ios app
URL of (my) website where problem appears:
sitepress.wpengine.com
I expected to see:
it work
Instead, I got:
NSXMLParserErrorDomain error 111
2015/07/14 16:59:04:620 Tracks sendQueuedEvents Called...
2015/07/14 16:59:04:623 Track sending events...
2015/07/14 16:59:05:170 No instructions, do nothing
2015/07/14 16:59:08:214 Tracks sendQueuedEvents completed...
2015/07/14 16:59:11:767 Error syncing post formats (hidden link): Error Domain=NSXMLParserErrorDomain Code=111 "The operation couldn’t be completed. (NSXMLParserErrorDomain error 111.)"
2015/07/14 16:59:11:771 Failed syncing post formats for blog hidden link: Error Domain=NSXMLParserErrorDomain Code=111 "The operation couldn’t be completed. (NSXMLParserErrorDomain error 111.)"
2015/07/14 16:59:11:775 Failed checking muti-author status for blog hidden link: Error Domain=NSXMLParserErrorDomain Code=111 "The operation couldn’t be completed. (NSXMLParserErrorDomain error 111.)"
2015/07/14 16:59:12:752 No instructions, do nothing
2015/07/14 16:59:14:070 Showing alert with title: Unable to Sync and message The operation couldn’t be completed. (NSXMLParserErrorDomain error 111.)

only occurs if I activate wpml - even in basic 2015 theme

July 15, 2015 at 8:08 am #659500

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for contacting our support forum .

Could you please review this : https://wpml.org/documentation/support/xml-rpc-language-interface/ .

Please let me know if that helps you.

July 16, 2015 at 12:01 am #660217

Bryan

Ahmed

I am not sure what to make of the article... this is NOT my APP it's the the WORDRPESS APP
hidden link

All I am trying to do is.

Make a post from the wordpress ios app with wpml installed...the main question is:

Has wpml tested wordpress app or ios ?
Does it work ?

Its the official app, wpml needs to support this.. with no special intervention IT just needs to work every time without failure or its impossible to use wpml for serious websites, don't you think ?

The test url I setup contains nothing other than toolset and wpml.
I spent a lot of time to get this ready for you guys so please treat the issue with the importance it deserves

thanks

July 16, 2015 at 8:22 am #660415

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your reply , and sorry for any inconveniences .

I have tried the Android app , and I couldn't make it work also , so It could be a bug or a compatibility issue , so I have escalated your ticket and one of our second tier support will be in contact with you soon .

Best Regards .

July 17, 2015 at 9:32 am #661346

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello, I am George from second tier support.
I have reproduced similar issue - while testing I was not able to connect at all.
However this seems to be known to our developers and it should be fixed in the upcoming new version of WPML.

Please make sure that this is not a compatibility issue with other plugin and theme that you might have. Please temporary switch all non WPML plugins off and test if this improves the situation.
We need to be sure that there is no other plugin that is interring with this functionality.

July 17, 2015 at 10:58 am #661440

Bryan

Hello George

no... no change, this is a test system so it ONLY had OnTheGoSystems software and I just deactivated every plugin and it worked fine... activated ONLY WPML Multilingual CMS and problem is back, even using base theme 2015.

its a test system so I can give anyone who like access to it.

is this forum general ? email me keniry@gmail.com and I will send the login details.

thanks

July 17, 2015 at 11:26 am #661466

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Thank you for testing.
At this time, credentials are not required - as I duplicated similar results - and I cannot even add a site to the app.
These errors should be fixed in the next release of WPML, that will be up very soon - perhaps next week.

July 25, 2015 at 4:14 am #666470

Bryan

Hi

any update on the fix ? I would really like to be able to test something tomorrow to meet a customer deadline.

thanks

July 27, 2015 at 6:26 am #666879

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello, this issue should be fixed in the next version of WPML - 3.2.3 or perhaps in the latest beta that we released available in Account > Downloads.

Please remember that if you try the latest beta - to do it on a staging environment and / or make complete website and database backup first.

February 2, 2016 at 1:14 pm #802481

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

The issue mentioned in this ticket is probably been resolved for some time.
I am just writing here to let you know that if you have waited for the release version, that that version should be already released and you have to give it a try.
Because of this ticket being open for so long, I am going to set it as Resolved.

Feel free to open a new forum ticket if you find out that the issue is still present and if you have any other difficulties.

Please remember as a guideline, if you are going to update, do remember to backup your database first before you proceed! You can use a plugin for this if you like (example: http://wordpress.org/plugins/duplicator/)