This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Shekhar Bhandari 6 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 18, 2019 at 9:29 am

bjornT-7

I've translated everything in Advanced Translation Editor.
As you see in the screenshots, I translated "Search & Filtering" but in the frontend it keeps showing in English instead of Dutch.

Also I can't get this error away:
"We detected a problem in your WPML configuration: the product_type taxonomy is set as translatable..."
I've tried things that I've found on the support-pages, but nothing seems to work.

April 18, 2019 at 9:48 am #3637897

bjornT-7

The issue of the "product_type" seems to be solved.
For those who have the same issue:
/wp-content/plugins/woocommerce-rental-and-booking/wpml-config.xml
Changing

<taxonomy translate="1">product_type</taxonomy>

into

<taxonomy translate="0">product_type</taxonomy>

Now still the translation issue 🙂

April 18, 2019 at 10:06 am #3638025

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please provide a link where I can find this search & filtering string? so I can check why the translation is not working.

Look forward to your reply.

Thanks

April 18, 2019 at 10:12 am #3638043

bjornT-7

Hello Shekhar,

On this page: hidden link

April 18, 2019 at 10:40 am #3638393

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I edited the page hidden link and on the

[reactive key="713"]

I correctly change the key id to the translated builder id and it's working perfectly, could you please confirm.

Kind Regards,
Shekhar

April 18, 2019 at 10:46 am #3638411

bjornT-7

Thank you, but it seems not working in Nederlands.
Form-fields are gone as well as the product.

April 18, 2019 at 10:57 am #3638601

bjornT-7

Also, I can't find the reactive builder you created (and linked on the Nederlands page) and the builder 713 is still locked by editing by you, is that correct?

April 18, 2019 at 10:58 am #3638605

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

As a test could you please follow the below steps and let me know if this helps:

- Backup your site
- Go to Reactive builder and edit the builder used on our trailers page
- Mark the rebuilder_post_type_select, rebuilder_taxonomy_select, rebuilder_meta_keys_select, reactivedata, reactivedata_en, reactivedata_nl
rebuilder_search_type to copy
- Click Apply
- Update the page.

Let me know if this helps.

Thanks

April 18, 2019 at 11:06 am #3638617

bjornT-7

I did that, but nothing seems to change.

April 18, 2019 at 11:10 am #3638659

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just checked and it looks like it's working, the form fields and the product is there, so could you please check it once again?

Thanks

April 18, 2019 at 11:11 am #3638661

bjornT-7

Yes, but it shows everything in English instead of Dutch.

April 18, 2019 at 11:44 am #3638885

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

This seems unusual, to further debug this issue, I would need to replicate your site on my localhost, so, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Enabled the private reply for you.

Look forward to your reply.

Thanks

The topic ‘[Closed] Don't show translation of Reactive Builds (from Turbo theme)’ is closed to new replies.