This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.27 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by rafaelM-22 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 3, 2018 at 6:12 pm

rafaelM-22

I am trying to: translate a "template" from WPBakery Page Builder that i use like bottom of my site.

Link to a page where the issue can be seen: hidden link

I expected to see: When i set the language "English", just need to show the english version of the bottom. Same thing for "Portuguese". But now, when I created the translation to the bottom, show me two bottons, English and Portuguese version.

Instead, I got: To show only one version of the bottom.

October 5, 2018 at 12:27 pm #2790684

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @rafaelm-22, welcome to the WPML support Forum!

The link you posted is displaying a 404 error, but I can still see the 2 footers in it.

Where in the WordPress dashboard is this footer being created? I searched it on the "Templatica" section but did not find it.

All the best,
Diego

October 6, 2018 at 3:00 pm #2792907

rafaelM-22

Hello, Diego, você também fala português, certo? rsrsrs

Estranho não ter aberto a página por aí, o link ainda é temporário, mas está público.

Para acessar o painel onde você pode encontrar isso no WordPress, vá em WPBakery Page Builder > Templates > Footer Coffee (terá a versão português e inglês).

Obrigado!

October 8, 2018 at 2:17 pm #2796410

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Olá Rafael. Sim, falo português 🙂

Eu erifiquei o seu website, e aparentemente o que ocorre é um problema de compatiblidade com o tema. Ele também não aparece em nossa lista de temas compatíveis: https://wpml.org/documentation/theme-compatibility

Uma solução rápida seria ocultar os elementos utilizando CSS. Você pode utilizar o atributo lang da tag HTML para aplicar CSS para apenas uma das linguas. Exemplo:

/*Hide on portuguese*/
html[lang=pt-br] .vc_custom_1533671359308, html[lang=pt-br]  .vc_custom_1534778763721, html[lang=pt-br] .vc_custom_1533671366362 {
  display: none;
}

/*Hide on english*/
html[lang=en-US] .vc_custom_1534778763721, html[lang=en-US] .vc_custom_1533671359308, html[lang=en-US] .vc_custom_1533671366362 {
  display: none;
}  

O problema no caso é que os elementos possuem as mesmas classes em ambos os idiomas. Você acha que é possível adicionar diferentes classes para cada idioma? Se sim, então só precisariamos adaptar o código acima.

Caso não seja possivel, as opções são:
- Modificar o código do tema e inserir o footer manualmente.
- Reproduzir o problema em uma instalação limpa e encaminhar para nossa equipe de compatiblidade, que irá entrar em contato com o autor para tornar o tema compatível.

Atenciosamente,
Diego

October 9, 2018 at 2:18 am #2797800

rafaelM-22

Diego, deu certo! Eu adicionei as classes portuguese-footer e english-footer nos respectivos rodapé e trabalhei na tag lang que você indicou, dessa forma consegui ocultar os itens. Apenas não fechei aqui porque gostaria que desse uma checada se está de acordo. Comigo funcionou certinho (fui me guiando pelo "Brasil" e "Brazil" nos rodapés, caso isso te ajude aí para conferir rsrsrs).

Vou fazer os testes no cabeçalho também, que é onde fico com mais receio por ser bem na borda superior do site, acha que teria de fazer algo diferente neles?

Muito obrigado pela ajuda!

October 9, 2018 at 4:25 pm #2801072

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Boa tarde Rafael,

Verifiquei aqui e parece tudo ok 🙂

Acredito que a mesma solução funcione ok no header. Apesar de ter verificado agora e aparentemente já esteja tudo ok.

Se precisar de mais ajuda estamos a disposição.

Atenciosamente,
Diego

October 10, 2018 at 3:17 pm #2804945

rafaelM-22

My issue is resolved now. Thank you!