This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:double flags on and out my header!

Solution:i was able to add the language switcher by going to WPML->Languages->Add menu language switcher

if you wish to only have one flag showing then go to the menu language switcher -> click on the "pencil " icon and uncheck the box for Langue actuelle

The reason you were not seeing the language switcher was because there are no translations added yet, WPML needs the translations in order to show the switcher , a way to get around this is the following.

WPML ->Languages -> Lien vers l'accueil de la langue pour les traductions manquantes

and also you can go to WPML->Settings->Post Type Translations-> posts/pages -> Traduisible : utilisez la traduction lorsqu'elle est disponible ou revenez à la langue par défaut

NOTE : please contact your theme provider regarding the snippet they gave you and ask them to provide you with a way to complete remove them because they still show on the English side of your site...they have done this for users before.

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by agenceB-2 12 months ago.

Assigned support staff: Bobby.

Author Posts
October 15, 2018 at 2:57 pm #2817998

agenceB-2

I am trying to:

1- display the nice language WPML switcher on my menu but unfortunatly it only display the first current language (has u can see on screenshoot included).
And after the loupe icon you can see another time the flags (how to not display thoses one?)

OR

2- if it's impossible to have the nice switcher on the menu, how to display a menu switcher insteed of the 2 flags as you can see on screen shoot include.

Link to a page where the issue can be seen:
hidden link (but have discard menu switch for my client seeing...)

I expected to see:
a nice menu switcher on my menu and that all.

October 16, 2018 at 11:57 pm #2822551

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

are you still experiencing this issue ? When i visit your site i can only see 1 language switcher with the option for both languages. (you mentioned you disacred the switcher , is this why i cannot see it now ? )

how are you adding this language switcher thats active now ? (WPML->Languages page ) ? its possible this switcher is being added by your theme.

from within the WPML->Languages -> Language switcher page you can edit the switcher to only show the secondary language and not show the current language

October 17, 2018 at 8:51 am #2823829

agenceB-2

Hi Bobby,
Has i told you i disable it because i don't want my client seeing such error.
To answer you: i didn't add anything for the 2 flags you can see now.
I need a menu selector insteed of that.

On the other hand, on my capture you can see the WPML language selector when i activated it. But the english language never open (always stay on french flag). So i disable it.

I just discover this morning that there is a bug on the menu language selector. There is on set but i can't erase it and it not display on front end...

Maybe it will be quicker if i give you credential to see on the backend what appen and how to solve as quick as possible?

October 17, 2018 at 6:29 pm #2825651

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

the current language switcher you are using is added by your theme if you are not adding it through WPML's language page.

if possible please contact your theme support to provide you with the correct code in order to disable that language switcher as they do know their code best.

"I just discover this morning that there is a bug on the menu language selector."

are you reffering to the one you can add through WPML-.Languages?

to provide me with access i have enabled the private field bellow

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

October 18, 2018 at 11:34 am #2827807

agenceB-2

forget your login: wpml

October 18, 2018 at 6:14 pm #2829201

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i was able to add the language switcher by going to WPML->Languages->Add menu language switcher

if you wish to only have one flag showing then go to the menu language switcher -> click on the "pencil " icon and uncheck the box for Langue actuelle

The reason you were not seeing the language switcher was because there are no translations added yet, WPML needs the translations in order to show the switcher , a way to get around this is the following.

WPML ->Languages -> Lien vers l'accueil de la langue pour les traductions manquantes

and also you can go to WPML->Settings->Post Type Translations-> posts/pages -> Traduisible : utilisez la traduction lorsqu'elle est disponible ou revenez à la langue par défaut

NOTE : please contact your theme provider regarding the snippet they gave you and ask them to provide you with a way to complete remove them because they still show on the English side of your site...they have done this for users before.

October 18, 2018 at 6:35 pm #2829230

agenceB-2

My issue is resolved now. Thank you!