This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
September 6, 2018 at 4:30 pm #2711729

jeroenM-5

I am trying to: get rid of the double products in the main language of the website (EN)

Link to a page where the issue can be seen: hidden link

I expected to see: only products in Dutch (NL) language

Instead, I got: products in both languages (EN, NL) in the NL version of the site. The english version displays the products as it is supposed to do. (only english products, not the dutch)

we import csv documents through the all import plugin. Maybe i didn't set the file up right?

September 7, 2018 at 9:39 am #2713927

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please if the products are imported correctly in the backend? Are the language assigned properly on the backend?

Look forward to your reply.

Thanks

September 7, 2018 at 10:23 am #2714099

jeroenM-5

Dear Shekhar,

thank you for your reply

Yes i followed the instructions. English (main language) was imported as Main language (default). And the Dutch language was imported as Dutch and then the automatic record matching was used, and a parent import was linked to the english version with a unique identifier => connector.

if you need, i can supply a wp log in / example file / everything you need.

Kind regards,

September 10, 2018 at 10:00 am #2719519

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

September 11, 2018 at 10:15 am #2723276

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

On the Accessories page I can now only see the "Zebra painted on goat skin" product once, so could you please let me know if the problem still exists, if yes, could you please provide me product name so I can debug it further.

Look forward to your reply.

Thanks

September 11, 2018 at 10:38 am #2723317

jeroenM-5

Dear Shekhar,

The problem is still there I think, hidden link on this page there still are double products. In English and Dutch.

i enclosed a screenshot with an example.

looking forward to your reply.

kind regards Jeroen

September 12, 2018 at 12:36 pm #2727532

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I tried to create a duplicator package but due to server restrictions I couldn't create it so could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

Enabled the private reply for you.

Thanks

September 21, 2018 at 4:40 am #2754028

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that you have only uploaded the database backup file, could you please upload the wp-content folder too? You can edit your previous private reply if you want to modify the link.

Look forward to your reply.

Thanks

September 24, 2018 at 3:10 pm #2760874

jeroenM-5

the new link to the drive is in the private message

September 25, 2018 at 11:42 am #2763529

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the doubled products are added in the same language as a reason the issue is happening. To fix this you have to remove the products and add it in the correct language properly.

You can find the step to step guide to import here: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Let me know if this helps.

Thanks

October 1, 2018 at 9:51 am #2777649

jeroenM-5

Dear Shekhar,

I followed the instructions very carefully, i also added a 'connector' The settings may still not be correct. Can you have a look with me in the import settings? What i do is define parent import in English language with the english import (main/default language) and then i import the Dutch list, in dutch import and i connect them in the wpml add on in all import, and i select the English import.

The dutch items are added. but the english products also come out on the Dutch page. They don't replace the english items.

In every import i enclose 2 lists. 1 in English and 1 in dutch.

the import template is in the website. Maybe you can have a look in the settings. As the unique identifier i use the 'connector'. May be this is not in the right place. in the documentation i see different lay out in settings then on my screen.

looking forward to your reply.

October 2, 2018 at 9:12 am #2780818

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that the unique identifier is different, I can see that you have used SKU as unique identifier elsewhere and on "Automatic Record Matching to translate" you are using connector id as the connector, please make sure to use the same unique identifier, this should solve the issue.

Thanks