This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.66 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 29, 2019 at 11:35 am

janneH-6

Hi,

I notice that, when WPML is enabled numbers of queries increases doubly and waiting to first byte is huge. Screenshots are attached.

Here is our store heaviest product page (bundle product with 6 products) hidden link

Is there a methods to reduse these queries?

Best regards,
Max

May 29, 2019 at 11:12 pm #3918999

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

In this case I recommend you to visit our page dedicated to prevent performance issues with WPML: https://wpml.org/faq/prevent-performance-issues-with-wpml/

Kind regards,
Carlos

May 31, 2019 at 6:01 am #3927927

janneH-6

Hi,

1. Optimizing WPML performance
Points 1-4 set by default in WPML. They are all set correctly
2. Checking your hosting setup
We have high performance VPS with 6 cores Intel® Xeon® 4114, E5-2630v4, 16GB ram, SSD, Centos 7.6.
3. PHP 7.3 and MySQL 5.7 versions
4. PHP settings
post_max_size = 1G
max_execution_time = 3600
max_input_vars = 2000
max_input_time = 3600

What I can try next? Thank you!

May 31, 2019 at 10:39 am #3929865

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

Please update all outdated plugins, themes and core and double check if the issue persists.

Regards,
Carlos

May 31, 2019 at 11:29 am #3930149

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

I also went to WPML -> Languagues -> Make themes work multilingual -> Deactivated this option and saved the changes.

Could you tell me if there is any improvement?

Regards,
Carlos

May 31, 2019 at 12:02 pm #3930355

janneH-6

Hi,

1. all plugins, theme are now succesufully updated.
2. "WPML -> Languagues -> Make themes work multilingual -> Deactivated this option and saved the changes" -> this is done. Same issue.
3. Is your plugin compatible with "WooCommerce Product Bundles" and "WooCommerce Product Add-ons" plugins? Heaviest bundle products in our shop (porto theme) have about 6 products and every product have about 200 queries to DB. 6 products x 200 = ~1200 queries without WPML plugin. When enabling WPML back the number of queries doubles.

May 31, 2019 at 12:11 pm #3930387

janneH-6

I also noticed that when enabling WPML and even if the product not translated, WPML doubles queries anyway. I tried that on super clean WordPress + porto with demo content version and same issue. Is that a normal?

May 31, 2019 at 12:37 pm #3930507

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Could you tell me if the issue persists with a WordPress default theme, like Twenty Nineteen?

Regards,
Carlos

June 3, 2019 at 5:50 am #3939431

janneH-6

Same issue with default theme.
Screenshots are below:

WPML enabled with default theme

WPML disabled with default theme

June 3, 2019 at 12:35 pm #3942265

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message and the screenshots.

I have created a test site with a fresh new WordPress installation, plus WPML and Woocommerce plugins. Could you tell me if you are able to reproduce the issue in this new install? This way we can rule out any possible conflict with a third party functionality.

You can access the test site by following this link: hidden link

Regards,
Carlos