This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: This is related to this ticket, please see for reference: https://wpml.org/forums/topic/add-support-for-download-monitor-addon/

I was informed to add some code to the includes/class-dlm-download.php file. The issue is that there is no such file in the download monitor folder. I have latest versions of WPML and Download Monitor.

Solution: Our compatibility specialists where able to 'translate' the Downloadable files/versions section using the WP standard editor. You can do this by manually switching the language in the admin menu at the top of the edit screen and clicking on 'Edit anyways' button.

So, here are the two possible solutions: -Use the standard WP editor and edit the translation to add the files again when is the same file. BUT have the possibility to have different files per language or -Try to reimplement the workaround (we need to check the code again as it may have change). You won't need to add the files again in the secondary language if they are the same. BUT, you won't be able use different files per language.

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 16, 2019 at 9:54 am #4218461

georgeM-9

This is related to this ticket, please see for reference:
https://wpml.org/forums/topic/add-support-for-download-monitor-addon/

I was informed to add some code to the includes/class-dlm-download.php file. The issue is that there is no such file in the download monitor folder. I have latest versions of WPML and Download Monitor.

Can you please advise?

July 16, 2019 at 12:01 pm #4219971

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Have you contacted the plugins authors and let them know about this issue?

Also, could you provide some contact information of the plugin's authors so I can pass it to our compatibility specialists? This way they will be able to get in touch and solve this issue.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

July 17, 2019 at 12:06 pm #4229797

georgeM-9

I have contacted the author a while ago, he has been postponing it for a while now. That's why I was wondering if there is anything I could do from my end. It's just this one field that needs to be translatable, couldn't you provide some code to fix it? Here is a link to another ticket I raised just now:
https://wordpress.org/support/topic/downloadable-files-versions-metabox-not-duplicated-in-wpml/

Author contact details can be found here:
https://wordpress.org/plugins/download-monitor/

2. Yeah, I did that but no change.

July 17, 2019 at 2:06 pm #4231023

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I have created a test site with a new WordPress installation, I also installed and setup WPML plugins with English as a default language and French as a secondary language.

I would like to ask you to log in the test site using this link: hidden link then install the necessary plugins and create test content to reproduce the issue.

If the issue persists then please describe the steps you followed to reproduce the issue.

Could you tell me the result of the steps above?
Regards,
Carlos

July 23, 2019 at 4:25 pm #4268077

georgeM-9

Hi there. Here is the process I follow:

I install Download Manager and activated
I go to WPML->Settings->Post Types Translation and set post types "Downloads (dlm_download)" and "Download Versions (dlm_download_version)" to be "Translatable - only show translated items". Note: I did not choose "Translatable - use translation if available or fallback to default language" since some downloads must only be available in English.

I create a new Download by going to Downloads->Add New. I set up a title, select the "Redirect to file" checkbox from the Downloads Option metabox on the right and upload a test PDF to the media library from the "Downloadable Files/Versions" metabox. I also create a new category "Category 1" and set the document to that category. I select Update. After the post is saved, I can see the "Downloadable Files/Versions" metabox which has one entry, the file that I had uploaded. Now, from the "Language" metabox on the right I deactivate "Use WPML's Translation Editor" and select the checkbox for Duplicating to the French language and click "Duplicate". I save the document again, just to be sure. From the top language menu, I switch to the French language. I can see the duplicated content all transfered from the original English language but if you have a look at the "Downloadable Files/Versions" metabox, the original uploaded file path has gone! I have to manually upload teh same document each and every time for each translation.

I hope I was clear!

July 24, 2019 at 11:46 am #4274187

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

There is one part in your previous message that I'm not sure about. If you need to show different files for different languages, why would you need to copy the files in the secondary language?

Note: Also, could you tell me if the issue persists if you translate the post using the Translation Editor?

Regards,
Carlos

July 24, 2019 at 12:31 pm #4274369

georgeM-9

For some files that are related only to the English language, I want them to appear ONLY in the English language and NOT in others. Then for most of the other files, I want to be able to duplicate them and have them available for other languages as well but with the original English content. For example, a datasheet download that has only imperial measurements needs to be available for English (actually my original language is US). Then a version of this datasheet needs to be listed with metric measurements so it can be visible to the original language but also in all the others if translations are not available.

I tried translating with the Editor as well but only the download title is being transferred to the editor.

I hope it's clear now.

July 24, 2019 at 1:22 pm #4275081

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I have escalated this ticket to our compatibility team. Our compatibility specialists will take a deeper look at the issue and will try to find a solution.

I will keep you updated about the evolution of this ticket.
Regards,
Carlos

July 30, 2019 at 4:26 pm #4309641

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Our compatibility specialists where able to 'translate' the Downloadable files/versions section using the WP standard editor. You can do this by manually switching the language in the admin menu at the top of the edit screen and clicking on 'Edit anyways' button.

So, here are the two possible solutions:
-Use the standard WP editor and edit the translation to add the files again when is the same file. BUT have the possibility to have different files per language
or
-Try to reimplement the workaround (we need to check the code again as it may have change). You won't need to add the files again in the secondary language if they are the same. BUT, you won't be able use different files per language.

Note: For a complete solution, we need the author's cooperation. Please, add the contact details.

Regards,
Carlos