This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 20, 2019 at 1:15 pm #4060139

mustafaC-6

Hello,

I need download my WPML plugins but when I click download button its download.html this is not a zip what's happened here?

June 20, 2019 at 11:39 pm #4063573

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

when you go to https://wpml.org/downloads/ are you still experiencing this issue ?

i just test it and its working as expected with the downloads being .zip

If possible please test with a different browser and let me know your results

June 21, 2019 at 8:57 am #4065593

mustafaC-6

Hello

Bobby, it's still not working for me. Can you please check this video. If it's possible please attachment plugins in this ticket I'll direct download or send me an email for files. hidden link

June 21, 2019 at 5:38 pm #4068769

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the video.

We recently saw a similar issue that happened due to some error in the user account, i have updated our systems team to take a look at this and will update you once i have news

at the meantime if you wish i can access your site and install the WPML plugin

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

Thank you,
Bobby

June 21, 2019 at 9:22 pm #4069287

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

were you able to successfully download the .zip file now ?

Within your Settings->Permalinks you have it set to "Default" , when using WPML you can have any permalink format set except default.

i have set it to post name now for you.

Regarding the issue you are referring to please verify that you have not installed WPML in a directory and also that you have rewritting enabled in your server , sometimes the best option here is contacting your host provider

let me know their feedback please

June 21, 2019 at 9:50 pm #4069341

mustafaC-6

Dear Bobby,

I have already install and activate and setup WPML on my website.
I don't need to use like this ?lang=ar
I need to use like this /ar/

Please tell me which folder need 777 permission? If you can login my website admin make anything on here :hidden link or via FTP manager. I don't understand how to fix this problem.

<3

June 21, 2019 at 10:51 pm #4069437

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please contact your host provider and verify

1. that your site is not installed in a directory
2. that rewritting is enabled in your hosting enviroment

and let me know their feedback

this is related to your site's hosting environment rather than an issue with WPML

June 24, 2019 at 2:18 pm #4077945

mustafaC-6

Hello Bobby, after weekend today I have call Godaddy company. They said "Your website is installed in a directory"

And for rewriting we can add manual via FTP. I have sent you details before can you help me about this problem please ?

June 24, 2019 at 6:32 pm #4079223

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Your Host provider confirmed that your WordPress is installed in a directory and not within the Root therefore you will not be able to use the language URL Format for Different languages in directories until WordPress is moved to the root.

your host provider should be able to help you set this up, unfortunately this is controlled by your host environment and is not a bug caused by our plugin or a 3rd party plugin.

i have verified this by creating a duplicator package and testing it on my local environment which works as expected.

please present your host provider with this issue and share with them the error warning you get from WPML as well with the information that this works as expected on a local environment and they should be able to resolve this from their side

June 24, 2019 at 7:24 pm #4079427

mustafaC-6

Hello

I think Godaddy never will help me about this problem. Ok let's try another solution.

I have added TR / AR and EN language for homepage. See here : hidden link

When click AR or EN link ast top bar left side this page not redirect /?lang=ar or /?lang=en

What is the problem?

June 24, 2019 at 9:24 pm #4079831

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

I have seen this issue before with GoDaddy , for example go to hidden link and you will notice it is working.

this can happen when the SiteURL or Home fields in the database table wp_options are empty.

please go to your wp_options table and let me know if your field siteurl and home are filled in , if one of them is missing its value fill it in with your whole URL and let me know your results

if you are not comfortable working with the database fields please provide me with your cpanel access to your phpMyAdmin and i can do this for you

The topic ‘[Closed] Download Now Working’ is closed to new replies.