This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by johannV-2 6 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 15, 2019 at 1:40 pm #3613815

johannV-2

On my homepage in the top section I have a search form for tours. This is showing "Start", "End" and "...". The "..." is for choosing a location and represents a parent tour category. In the drop down menu its showing child tour categories. All those categories (parent and child) are translated but the parent category wont show up as translated. My theme support suggested me to contact you guys about this issue as they cant figure out how to make this work.

April 15, 2019 at 1:45 pm #3613847

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I split the ticket so it would be easy to focus on this issue.

I just replicated your site on my localhost and try to see those categories and it seems to be showing correctly, here is the screenshot.

Could you please provide a few screenshots showing how you can see those lists?

Look forward to your reply.

Thanks

April 15, 2019 at 2:22 pm #3613977

johannV-2

The list itself is fine. It's showing all the child categories as translated ("Puno","Nazca","Machu Picchu",etc.). The problem is the parent category "..." on top of the list. This is translated in German for example as "Wohin geht's?" and should be shown like that. Instead it's showing in all languages as "...". Do you get the problem? Please look in the backend dashboard for Products>>Tour categories and then for the category named "...". This has some translations which are not showing up correctly. Sorry but can be confusing as all the translations are quite similar.

April 16, 2019 at 6:12 am #3618373

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The tour category is saved as theme options so to show the correct category on the translated page, please follow the below steps:

1) Copy the following code in WPML->Settings -> Custom XML configuration

<wpml-config>
    <admin-texts>
        <key name="adventure_tours_theme_options">
            <key name="tours_search_form_start_category" /></key>
    </admin-texts>
</wpml-config>

2) Once you place the code there, go to WPML->Settings-> Multilingual content setup and refresh the page.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

Once you have created language configuration files you need to go to WPML->String Translation and search the strings that you have inserted in the theme options and translate it for the secondary languages.

You will find the ID of those category registered, so on the translation add the translated category id to solve the issue.

Let me know if this helps.

Thanks

April 17, 2019 at 4:09 am #3627085

johannV-2

Yessss. That works. Thank you Shekhar.
Resolved!

April 17, 2019 at 4:11 am #3627087

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Glad to know it worked, you can mark the ticket as resolved now.

Thanks

April 17, 2019 at 4:38 am #3627119

johannV-2

My issue is resolved now. Thank you!