This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 1 month, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
August 21, 2019 at 9:02 pm #4435041

adwin

Hello it seems the dropdown menu is doubling up... you see it says english english, it does the same when you switch to Chinese.

Also, in the top header you will see Call Us: 604-366-8897

Is this done through string translation? When I click on there that section does not appear

Thanks for your help!

August 22, 2019 at 6:31 am #4436705

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. are you using the default language switcher from WPML -> Languages -> Menu language switcher

or is this a custom switcher ?

2. please verify that you are using the latest version of your X theme as you are using a child theme at the moment

if the theme is up to date and you are using a standard language switcher

i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

August 22, 2019 at 7:33 pm #4442475

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

My apologies as i believe i must have misunderstood the issue. I was under the belief that the menu was double when you would scroll over the drop down as this was an older issue that has now been fixed.

the issue being English (English) can be resolved by the following steps

Go to WPML->Languages -> Edit Menu language switcher (pencil icon)
Uncheck : "Language name in current language" or "Native Language Name" and save

please check your front end now and let me know if that shows as expected

August 22, 2019 at 7:47 pm #4442535

adwin

This is works great, i do have a secondary issue now

How do I translate the phone number at the top

Is it in String Translation? When I go there, it does not appear

Thank for all your help!

August 22, 2019 at 8:50 pm #4442853

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

That string is an admin string that is listed under x_topbar_content

Go to WPML->String Translation -> select strings within domain and filter by "admin_texts_x_topbar_content "

then translate it there

let me know your results

The topic ‘[Closed] Dropdown Doubling up’ is closed to new replies.