This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem Duplicate content doesn't work at all…:

Solution:Marked all fields in settings as "translate" and for now all works fine.

Relevant Documentation:

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by MeLJes 3 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 26, 2019 at 1:32 pm

MeLJes

Hello guys!

So, the problem next: i'm try to duplicate content to other lenguages, but content doesn't show in fields (all empty)... All WPML settings i'm took from other site, where all works fine. In support page, advanced options tab, i clear all caсhe, but still nothing...

June 26, 2019 at 7:05 pm #4094721

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if possible please provide me with some additional information as at the moment i am not able to see the issue you are experiencing.

i have checked your site and all languages seem to work and to be translated.

which page or post are you having trouble with duplicating ? Please provide me with the steps i need to follow to reproduce this behavior so i can better understand the issue

also i can see that you are not using the WPML Translation Editor , does the problem arise when using the Translation Editor ? do you only see the title field rather than the body ?

June 27, 2019 at 7:15 am #4097227

MeLJes

Hello, Bobby!

I made small video about my problem, available in my GD: hidden link

Currently all translates are made by myself, not with duplicate function.

June 27, 2019 at 7:23 pm #4102435

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the screencast !

this is happening because you have set your custom fields to be "Don't Translate"

within the default language page scroll down to the bottom and view the Custom fields

they were set to "Don't Translate" , i have set them to "Copy" now and that should resolve the issue.

June 29, 2019 at 3:40 pm #4112167

MeLJes

Hi, Bobby!
Before I create this ticket I use this steps and all my fields was set to copy. But in this case after duplicate my content I can’t change anything - after update all return to original. And in my previous sites all this fields set to don’t translate and it’s all work. Idk what happens here... Maybe there was some major update witch change plugin work logic?...

July 1, 2019 at 5:22 pm #4121377

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if possible please confirm that following these steps has resolved the issue

The correct way would be for these settings to either be at "copy" or "translate" as they are responsible for the layout of your page.

this is the expected behavior as i have test it on my environment as well

July 1, 2019 at 5:57 pm #4121519

MeLJes

Marked all fields in settings as "translate" and for now all works fine. Idk how my previous sites work without this settings, but it's dosen't matter for now. Thanks!