This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.14 hours from now. Thank you for your understanding.

This topic contains 25 replies, has 2 voices.

Last updated by anthonyG-21 1 month, 4 weeks ago.

Assigned support staff: George Botsev.

Author Posts
August 15, 2019 at 2:05 am #4398211

anthonyG-21

I am trying to: Not spend a ton of money on tranlsations

Link to a page where the issue can be seen: hidden link

I expected to see: Only the content I choose to be translated (and only see it once).

Instead, I got: See the red boxes in the attached image, I cannot tell where the duplicate content is coming from for the given page, and the second red box, I don't want this translated at all. I cannot figure out the source of these things on my page. Here's the page I want translated: hidden link

Thanks!

Tony

August 16, 2019 at 12:12 pm #4406209

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello and thank you for contacting us.

Did you test to re-send the job to translation via the Translation Management Dashboard?

Do the problem happens with more than one page/post?

Have you tested for a new page/post if you can reproduce the problem?

Could you please provide access to your site, as currently I cannot visit the job that you have provided above.

August 16, 2019 at 2:00 pm #4406773

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I checked your site.
It seems that you have two fields that hold the same (almost the same) data
Because I opened the old job from the Chinese translation - it shows probably the old contents and you might have to re-send to translation in order to display the new values.

I made a screenshots for you - for me everything is looking good - because they are two different fields and they are selected to be translated both of them.
(screenshot1)
The field with the Ids is also selected to be translated and that is why it is showing in ATE too
(screenshot2)

August 16, 2019 at 2:12 pm #4406893

anthonyG-21

Great, this is the level of detail I need! Thanks! I don't need the imageid fields, and they don't show up in the custom field search (see attached image). Do you know how to suppress this?

Thanks!

August 16, 2019 at 3:08 pm #4407213

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

This seems to be a shortcode and not a custom field.
That configuration is coming from your theme wpml-config.xml (Your parent theme in your case).
There is this:

        <shortcode>
            <tag>fusion_imageframe</tag>
            <attributes>
                <attribute>image_id</attribute>
                <attribute>gallery_id</attribute>
                <attribute>lightbox_image</attribute>
                <attribute>alt</attribute>
                <attribute type="link">link</attribute>
            </attributes>
        </shortcode>

You can try and add the same code in WPML > Settings > Custom XML Configuration, but add there: ignore-content = "1" as noted in https://wpml.org/documentation/support/language-configuration-files/#1-2-translate-media

However I have not tested that.

<wpml-config>
  <shortcodes>
        <shortcode>
            <tag ignore-content="1">fusion_imageframe</tag>
            <attributes>
                <attribute>image_id</attribute>
                <attribute>gallery_id</attribute>
                <attribute>lightbox_image</attribute>
                <attribute>alt</attribute>
                <attribute type="link">link</attribute>
            </attributes>
        </shortcode>
  </shortcodes>
</wpml-config>
August 16, 2019 at 5:49 pm #4407761

anthonyG-21

Thanks, I tried using that code, but unfortunately that did not work. This is coming from an image within Fusion Builder (Avada Theme). The code was valid XML, just unsure why it's not working correctly.

August 19, 2019 at 7:14 am #4413899

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Please make sure that after you set the values in WPML > Settings > Custom XML that you sent the content again for translation and complete first the previous job translation.
Without sending the content again it is possible that old data is loaded and the same fields are displayed.

August 19, 2019 at 7:15 am #4413903

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Or perhaps test with a new page.

August 19, 2019 at 11:22 am #4415525

anthonyG-21

That was the first thing I tried. I sent a new page over for translation. It didn't work.

Thanks,

Tony

August 19, 2019 at 11:47 am #4415639

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I am sorry that this is not working.
As this is not a compatibility issue, as some people might want to translate these values, I think this is more suitable as a feature request.
In this case, I suggest that you use the form at https://wpml.org/suggest-a-new-feature-for-wpml/ and suggest a new feature to ignore certain records.

August 19, 2019 at 11:51 am #4415699

anthonyG-21

George,
I'm not sure it's a compatibility issue, I think it's an XML issue, please see the attached XML as entered. I just can't figure out what to target with the XML, so I used your XML verbatim.

Thanks, Tony

August 19, 2019 at 12:14 pm #4415813

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I generated that XML based on your parent theme xml.

The issue is in the shortcode fusion_imageframe

I checked our original file and it is different from yours.
Your file contains:

<shortcode>
    <tag>fusion_imageframe</tag>
    <attributes>
        <attribute>image_id</attribute>
        <attribute>gallery_id</attribute>
        <attribute>lightbox_image</attribute>
        <attribute>alt</attribute>
        <attribute type="link">link</attribute>
    </attributes>
</shortcode>

and ours:

<shortcode>
<tag type="media-url">fusion_imageframe</tag>
<attributes>
<attribute>image_id</attribute>
<attribute>gallery_id</attribute>
<attribute>alt</attribute>
<attribute type="link">link</attribute>
<attribute type="media-ids">image_id</attribute>
</attributes>
</shortcode>

I have several suggestions based on that:
1. Perhaps you should update your parent theme.
2. Perhaps you should try to change your parent xml code to match ours
3. You should add a wpml-config.xml in your child theme that will override the parent theme xml
4. You can try our code in the settings of WPML for custom XML
5. Perhaps you may try to remove some of the attributes of that shortcode, and leave only what you need to translate.

August 19, 2019 at 12:35 pm #4415995

anthonyG-21

I copied the parent theme's config file to my child theme, then ignored the tag there, this seems to be the most straightforward approach, but it did not work. I also added both provided codes to the settings in WPML back-end. It's crazy that these IDs are still persisting over to the translation. Wouldn't WPML be reading the config file from my child theme?

Tony

August 20, 2019 at 9:34 am #4422171

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I am sorry, I think I gave you the wrong directions here.
You should change the parent theme wpml-config.xml as it is said in https://wpml.org/documentation/support/language-configuration-files/#using-wpml-language-configuration-file-with-child-themes

If you are using a child theme, the language configuration file of the parent theme overrides the one found in the child theme. WPML provides a configuration page that allows you to easily override this with any custom settings.

August 20, 2019 at 12:54 pm #4423795

anthonyG-21

Hi George,
This is officially a bug. I have the ignore flag set in settings, parent, and child theme. Yet the IDs still flow over to the advanced translation editor. These are fusion image fields, part of the fusion builder and the popular WP theme Avada. WPML claims to work with Avada. How can I submit a bug report? Thanks!

Tony