If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When I translate my page builder content, I see some fields duplicated.

Solution: This is a bug which will be fixed in next version. Meanwhile, we created an errata page with a patch https://wpml.org/errata/duplicated-fields-in-translation-editor-for-page-builders-divi-visual-composer/.

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by georgeM-9 2 years, 6 months ago.

Assigned support staff: Pierre.

Author Posts
May 15, 2017 at 10:50 am #1275979

georgeM-9

Hello. I sometimes get duplicated fields in translation editor for Visual Composer. For example, I modified a few fields on the original language, then headed to the translated pages I can see those fields duplicated on the translated content. I understand that this might be an issue that will be fixed in the next version as described in the page here:

https://wpml.org/errata/duplicated-fields-in-translation-editor-for-page-builders-divi-visual-composer/comment-page-1/#comment-1627011

however the proposed solution didn't work with Visual Composer. I still get duplicated content even after clearing WPML cache.

Can you please help?

May 15, 2017 at 5:54 pm #1276504

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi @georgem-9,

This is Pierre from https://wpml.org/errata/duplicated-fields-in-translation-editor-for-page-builders-divi-visual-composer/. I will try to handle this ticket 🙂

The issue you are experiencing might not result from the same cause as the one related in the errata. To debug and sort this out, I need to deploy a local copy of your site. Could you provide me with a Duplicator package (https://wordpress.org/plugins/duplicator/)?

I will also need the steps to reproduce the issue (if any).

Your next reply will be private so you can share the download link for the package.

Thanks,
Pierre

May 15, 2017 at 9:04 pm #1276656

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks @georgem-9,

I will investigate the issue on your snapshot and I'll get back to you ASAP.

Regards,
Pierre

May 16, 2017 at 1:37 pm #1277274

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi George,

I have some questions because I can't reproduce the issue as you described (with the patch of course):

1. Did you test the patch that we provided in the errata (https://wpml.org/errata/duplicated-fields-in-translation-editor-for-page-builders-divi-visual-composer/). In the snapshot you provided, I can't see it.

2. When you update the original page, are you on the backend or frontend editor?

3. Could you create a screencast with all the steps you take?

Note that you well need first to complete all "in progress" translation jobs in order to refresh all the translation fields.

I am waiting for your feedback,
Pierre

May 16, 2017 at 4:21 pm #1277500

georgeM-9

Hi Pierre, happy to answer your questiosn:
1. I did try the patch which it didn't work so I restored with the original version before I send it to you.

2. When I update the original page, I am on the backend.

3. Please try and view the translated versions of "Management Software – Features" pages from the backend. They have two VC fields duplicated at the bottom. Try deleting one of the translations, put it to the Trash, then try recreating it by clicking the + button. The two extra fields are still there at the bottom. I just tested that, it should be the same in your end.

May 16, 2017 at 5:07 pm #1277531

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi George,

So I tried and followed you guidelines (with the patch):
1. Edit page "Management Software – Features" (in English - source).
2. Open the translation editor in French => I can see a duplicated field at the bottom about "License Server Support".
3. Go back to the source page edit screen and click on the update button.
4. Open the translation editor in French => I can't see the duplicated field anymore.

Please check the screencast I have recorded hidden link and let me know if there is something wrong with my steps.

Regards,
Pierre

May 16, 2017 at 7:47 pm #1277628

georgeM-9

Aha, ok I see. I hadn't actually saved the original source page again! Once I did and headed back to the translated page through the Tranlsator Editor the duplicated content wasn't there. That's great! Only question I have is I noticed that the two bottom Visual Composer sections on the translated pages ('Improved Fault Monitoring' and 'License Server Support') appear now at the bottom of the translated page's translation editor even though their actual original order on the page (they were supposed to appear just after the section starting with "Digital Watermarking"). Any idea why that has happened?

May 16, 2017 at 8:01 pm #1277635

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi George,

I am happy to hear this works now 🙂

Concerning the text blocks order, this is the expected behaviour currently. It depends on the order the strings are added to the database, and not according to the way it's displayed in the post. So yes, when a string is removed and replaced with a new one, it shows up at the bottom of the translation editor.

This is a possible feature improvement for the future and I will share it with the team, but I can't promise it will be ever implemented.

Thanks,
Pierre

May 16, 2017 at 8:26 pm #1277648

georgeM-9

Ok, I hope you let the team now then. Thanks again for your help!