This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 5 months ago.

Assigned support staff: Andreas W..

Author Posts
May 13, 2019 at 3:18 pm #3800003

boonyawatL

I am trying to: Click on a logo on my webpage to go back to homepage, then I got 404.

May 13, 2019 at 3:40 pm #3800183

boonyawatL

It seems like, when clicking on shop logo it directs to hidden link which it will then be hidden link. You can also get this error when manually type in hidden link in URL box. But if you type in hidden link (with the / at the end) it will goes to correct page - homepage. I think the question is how can I fix this when clicking at logo on website? Thank you very much. This is quite urgent as I will have an exhibition later this week.

May 13, 2019 at 9:53 pm #3801773

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

We had similar issues in the past. Please try the following:

Disable all plugins. Switch to a default theme. Then go to Settings -> Permalinks and I change the permalink structure first to (date, title - as example) and save it. Then reactive the currently used theme and the plugins and the URL should show up correctly. Then changed the permalink structure again to your preferred choice.

I hope this will solve the issue. Let me know if you need further assistance.

Kind regards
Andreas

May 14, 2019 at 2:13 am #3802565

boonyawatL

Hi Andreas,

I found this...https://wpml.org/forums/topic/double-language-url-when-redirected-to-the-home-page/#post-3800341

This is exactly what I encounter... Before I try your recommendation, is there other ways easier to solve this? I am not a developer so the easier solution the better for me. 🙂

Thank you
Boon

May 14, 2019 at 3:23 am #3803089

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

The topic ‘[Closed] Duplicate /en/en/ when going back to homepage’ is closed to new replies.