This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 17, 2018 at 4:21 am #2739606

carecweb

Hi WPML Support,

The ff. methods for updating/setting the featured image for the translation are not working:

1) Given an existing completed translation, checking "Duplicate the featured images for translated content" and clicking "Start" from WPML->Settings->Media Translation did not do anything.

2) With the "How to handle media for new content: Duplicate featured images for translations" checked and then "Apply clicked", create a new translation and complete it. Again feature image from the original post was not carried over to translation.

3) Given any of the two above (translation already completed), go to the original post, click "Duplicate featured image to translations" on the right sidebar and click "Update". Again, nothing happens.

The only thing that work is

4) Go the translated post, check "Duplicate featured image from original", and then click either "Save Draft" or "Publish".

Is this expected behavior or is this a bug? Does that mean that you cannot copy the feature images by bulk (unlike the other two options: 1) Make media available to all languages and 2) copy attachments to translations) and that you have to go to each translation and do number 4) ?

Thanks

September 18, 2018 at 8:06 am #2743970

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

It may be happening because of the compatibility issues. Are you able to reproduce the issue with a new Post?

Please do the bulk edit for the Posts and check the featured images are copying or not.

Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking. Please check the following links for more details about our private information sharing policies.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

The topic ‘[Closed] Duplicate featured images for translations – not working batch and single mode’ is closed to new replies.