Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 55 replies, has 31 voices.

Last updated by John 5 years, 5 months ago.

Assigned support staff: Minesh.

Author Posts
September 7, 2014 at 7:27 pm #465260

annaT

Since updating to WordPress 4.0 the WPML media translation widget doesn't work properly any more. I checked all my widgets and deactivated them and I'm pretty sure that WPML is causing the trouble.

I get thousands of duplicate images whenever I make changes to an existing image (I haven't tried uploading a new one yet) – and the weird thing is that the duplicate images don't seem to be uploaded to the server (not in the WP upload folder at least) - they just show up in the WordPress backend as ghost images without a thumbnail. I can delete them from the backend by hand in my main language but I can't access them in my subfolder language at all. Before the update, there was a link to changes languages in the media library - which has disappeared with the 4.0 update.

Unfortunately, google tries to access these ghost pictures and I get thousands of crawl errors. I'll upload a screen shot so you can see the problem. You'll also see that I have started to delete pictures by hand and that there is a total of more than 21.000 images somewhere and only less than 3000 images in the English folder (because I already deleted the other 12.000 or so). While there should only be around 500 pictures in total...

September 7, 2014 at 10:11 pm #465300

rebecaD

I am having the exact problem!!!

September 8, 2014 at 5:42 am #465338

Minesh
Supporter

Thank you for contacting WPML Support!!

Can you please get in touch with us with answer to next questions:
=> Can you please try to deactivate / activate WPML plugins once and check you have still issue?
=> Can you please share screen shot of WPML => Support Page
=> Can you please tell us what is your WordPress version?
=> Can you please tell us Which theme you are using? is it public?

September 8, 2014 at 6:38 am #465367

annaT

Dear Minesh,

sure:
when I deactivate WPML media translation management, the problem ceases to exist. When I activate it again, it appears once more.

I'll upload the screenshot of the support page. My wordpress version is 4.0 and problems started with that update. The theme is Moka by Elmastudio hidden link

Apart from solving the duplicate image problem: Can you think of a way to get rid of the duplicate images that are there already - except deleting them by hand (which consumes too much time)?

September 8, 2014 at 10:45 am #465580

Minesh
Supporter

Thank you for sharing information!!

***Please take FULL BACKUP of your database and website.***

By reviewing your information we found that you are running with older version of WPML plugins. Updating is simply the first step in troubleshooting issues. It is required because fixes are provided in the form of updates.

Can you please upgrade your plugins to latest released versions, You can find WPML latest released versions at:
=> wmpl.org => Your Account => Downloads

September 8, 2014 at 5:49 pm #466056

susanned

I have the same issue. After deactivating the WPML Media plugin the problem is gone. I have the most recent WPML updates. Will there be an update in the short future?

September 8, 2014 at 6:33 pm #466083

rebecaD

I deactivated the media plugin and the problem is gone! Thanks!

September 9, 2014 at 10:39 am #466564

miguelT

We need an URGENT FIX on this ASAP!!!

September 9, 2014 at 11:03 am #466592

annaT

If I had known that there was an update, I would have updated the plugin. Unfortunately, I didn't get any notification of the new version like usually.

I have by now deleted all ghost image copies from the database but once I reactivated the media translation plugin, the problem started appearing again. So that didn't solve the problem.

September 9, 2014 at 11:22 am #466613

Minesh
Supporter

@miguelt , rebecaD, susanned:
Can you please open new tickets for your issue.

@annat:
***Please take FULL BACKUP of your database and website.***

In order to investigate your issue if you like I could check things on your install in order to see what could be going wrong there.

If you agree to this please use the form fields I have enabled below to provide temporary access details (wp-admin and FTP)?

I have already enabled next reply as private.

***Please do not forget to take FULL BACKUP of your database and website.***

September 9, 2014 at 11:24 am #466615

miguelT

Why would I open a new ticket when the problem is described exactly over here ?

September 10, 2014 at 10:45 am #467486

Minesh
Supporter

@miguelt,
Can you please get in touch with us with answer to next questions:
=> Can you please share screen shot of WPML => Support Page
=> Can you please tell us what is your WordPress version?
=> Can you please tell us Which theme you are using? is it public?

@annat,
=> Can you please send us your access details.

September 11, 2014 at 9:05 am #468317

patriciaD-5

Hallo

When you going to fix this problem???

September 11, 2014 at 9:10 am #468325

Minesh
Supporter

@patriciad-5
Can you please get in touch with us with answer to next questions:
=> Can you please share screen shot of WPML => Support Page
=> Can you please tell us Which theme you are using? is it public?

We will require your temporary access of your install in order to fix your issue.

September 12, 2014 at 4:39 am #469159

Samir

I hace the exact same problem.
I already updated all plugins to latst versions, however I cannot delete ghost images from WordPress backend. I surely delete theme, but after refresh I see all of them again.
In the server, files image files don't exist.
Please help!