This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Radu 4 months, 1 week ago.

Assigned support staff: Radu.

Author Posts
May 21, 2019 at 8:25 am #3853187

Julia

I want to deactivate wpml on some sites we have it installed.

We tried some solutions that are posted on the forum, but they dont give a nice result.
Like:
https://wpml.org/forums/topic/deactiving-the-wpml-media-translation-plugin-created-many-duplicates/#post-878730

There must be a way to simply deacticate WPML without having media problems.

What we see is that our images are duplicated when wpml is deactivated. Also in the frontend the images of a not default language (lets say italian) are now showing up on our default language (dutch) mages. Givin ofcourse SEO issues and position drops for these pages.

This issue must be known by WPML and i want to know the official and correct way to deactivate wpml without all these issues that arise.

How can we do this?

May 21, 2019 at 10:14 am #3854163

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Juia,

Thank you for reaching out the WPML support!

Can you tell me why do you want to deactivate the WPML Media plugin, please? Do you want to stop having the website with more than one language? I'm asking this because you mentioned that the images on the translated pages are messed up once you deactivate the plugin. Basically, the reason why you need to keep using the WPML Media plugin is to make sure that the right images are shown in each language. I asked for more info about this because I want to understand exactly what you'd like to do (and why do you want to deactivate this plugin) so I can point you to the right solution.

Thanks,
Radu

May 22, 2019 at 8:20 am #3862905

Julia

Hi Radu,

Thanks for your reply. We want to stop having our website multilingual.

We all ready have the other (not default) languages hidden. But we want to remove the WPML plugins completely to clean things up. Unfortunately this is giving a lot of problems with the images. FYI this is happening on all the websites we have wpml installed.

Hope you have a clean and fast solutions to fix this.

Julia

May 22, 2019 at 10:12 am #3864141

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

Have you tried to use the Reset option from Dashboard → WPML → Support → troubleshooting link? This should take care of removing anything related to WPML (except for content that you'll need to remove by yourself). Can you give it a try and tell me how it goes? You can create a backup for the website first in order to be able to roll things back if anything goes wrong.

Thanks,
Radu

May 22, 2019 at 12:58 pm #3865751

Julia

Hi Radu,

I have the feeling i am a testcase to test the solutions you describe.

How will this complete removal relate to the images that were imported during the time wpml was installed. Because when i deactivate all wpml plugins, the images get duplicated because wpml added them in the database in such a way that this issue arrises.

Also i would like to know if this is the right way to remove wpml without the image, category and other possible issues that arise. I would imagine that you guys tested this extensively and experienced this problem in your tests.

Please advise.

May 23, 2019 at 7:50 am #3872169

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

When it comes to uninstalling the WPML plugin, there's the reset option that you can use (the one that I mentioned before - https://wpml.org/faq/how-wpml-reset-works/). This option is only removing the database content. In this case, everything related to content (media, posts, pages, and any other post type) need to be removed manually. In this case, all you have to do is follow these steps (before using the reset button from WPML → Support area):

  • go to Dashboard → Pages;
  • change the language from the top admin bar to the secondary one;
  • delete all the pages;
  • repeat the steps 1-3 for all the other post types (posts, media).

Once you did this, you can go to WPML → Support → Troubleshooting and use the reset option. Can you give this a try and tell me how it goes, please?

Thanks,
Radu

May 23, 2019 at 8:21 am #3872467

Julia

Hi Radu,

The option you mention will NOT work. We did this before..... e.g. went to the media, selected the secondary languages, and removed the images for that language. This resulted in the images also to be gone in the default language...

May 24, 2019 at 5:26 am #3881201

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

Is there any chance that you could give me access to your website dashboard area so I can have a look at this and see what's going on, please? The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

May 24, 2019 at 11:48 am #3884417

Julia

HI Radu,

Hereby login credentials for one of our sites that is less important than our shop site. But the same issues are arising here. If you have a good solutions we can use this to fix this issue for all our other websites.

login credentials removed - reply was not private!!!

May 24, 2019 at 12:52 pm #3884845

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

Thank you for sharing the credentials. I copied them right before you changed the message.

I investigated this issue a bit closer and it seems that this is related to our plugin and it's already escalated to the development team. For now, you can activate back the WPML and WPML Media plugins, go here: hidden link, select each secondary language from the top admin bar, and delete the images manually. Just leave only the images from default language (Nederlands) untouched, and then deactivate the WPML plugins. This should work well as a workaround.

Thanks,
Radu

May 24, 2019 at 1:30 pm #3885309

Julia

HI Radu,

Like mentioned we did that before, but that resulted in the images being also deleted in the dutch version.

May 29, 2019 at 9:15 am #3913777

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

Can I upload an image to your website and try to delete it, please? I don't want to alter your existing content and that's why I want to upload a new image. I tried to replicate this issue on my side several times but everything worked fine. This is why I want to try this on your site too.

Thanks,
Radu

June 4, 2019 at 8:00 am #3948975

Julia

sure you can.
As you can see the images now have the italian titles.... but the italian language is deactivated.

I noticed this website is probably not a good example because duplicate images doe not exist here. Or did you do something to remove the duplicates for this blog?

But here the italian titles is yet another strange thing that is happening.

If you want i can create a login for the other blog where this is happening. If so please provide an secure post for us to give you the credentials.

Julia

June 7, 2019 at 8:37 am #3974835

Julia

Hi Radu, any news on this?

The images have titles in the other language, we would like to fix this asap.
As i can assume it is affecting our seo.

June 10, 2019 at 12:06 pm #3987289

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Julia,

It would be great if you could create a login for me on the other blog where I can see this issue. I'll import an image and see how things work. The next message is private so you can safely send me the credentials.

Thanks,
Radu

The topic ‘[Closed] duplicate images when deactivating wpml’ is closed to new replies.