This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 11 replies, has 2 voices.

Last updated by mattiasR-3 3 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 19, 2019 at 4:04 pm #4053113

mattiasR-3

Hello,

I tried to create Duplicate in other language with WPML (WP and all plugins are updated to the latest versions and there's no custom Developments) / Image 1

.. but none of the Custom edits in left side of elementor came over to Duplicate page in other language (WPML Duplicate vs Original) / Images 2-3

Tried translate independently, without it, turned off all the plugins - including tried without Elementor PRO as well / Image 4

Even tried with translation Editor but got the same result all the time / Image 5

Can You help please?

Mattias

June 20, 2019 at 11:51 am #4059585

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

- Could you please log into this site:
hidden link

- Upload and install Elementor that you are using.

- Then attempt to recreate this problem using a new page with only this element in it?

Thank you so much for your collaboration.

June 25, 2019 at 2:44 pm #4085587

mattiasR-3

Sorry for the late reply but got an Error before and somehow my post got lost and had no time. So now...

I added plugins and tried to Duplicate (Default EST language -> ENG). Same results that only info that's duplicated in Elementor post through languages is text. But no settings on the left side. You can see that with Testleht in EST (original) and Estleht in ENG (Duplicated but without any Elementor settings on the left side)

Hope You can help since there's coming some bigger websites as well and really would like to use both Elementor and WPML like this.

Thanks,
Mattias

June 25, 2019 at 3:58 pm #4086125

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´m not too clear on what you mean by "no Elementor settings on left side".

When I veiw the two pages on the frontend, they look the same - so exactly which settings are not being copied?

If I turn "off" the WPML editor, and then edit the translated page with the Elementor Editor, then I see the same values in the widget settings for each language.

Could you please indicate in a screenshot which settings you do not see the same in each language?

July 1, 2019 at 9:36 am #4117085

mattiasR-3

Hey,

Just can't get Duplicate - just as I have in my main site. (2 images)
EST Original is here: hidden link
and ENG Duplicate is: hidden link

Not sure how this happened that previos one went OK. Or was there delay? Very odd... but I always get this result when I Duplicate with WPML in Edit Page (Translation Editor turned on or off, no change).

July 1, 2019 at 3:26 pm #4120833

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Interesting.

I am still not able to replicate this! I´ve tried 2 times (WPML1, WPML2). In each case, with Translation Managament modules activated and using the Translation Editor, the page duplicates and the section structure is preserved

Can you try one more time and be very specific about the steps that you do to create the problem?

July 2, 2019 at 7:04 am #4124437

mattiasR-3

So I think I'm doing something "wrong".

I went to page, clicked Duplicate. Then I had the page in Spanish hidden link

Clicked Edit and Popup I put Translate Independently. It opens translation in WPML Translation editor but since I want to change Elementor, I went straight to Pages - Spanish - Edit with Elementor. And that's how I always end up without Elementor settings.

What's the step I'm missing when Duplicating?

July 2, 2019 at 7:42 am #4124733

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK.

Try this workflow instead:

1. Click Edit
2. Translate Independently
3. Accept to edit in Translation Editor - mark everything as complete - "Save and exit"
4. Then, go to Pages > Spanish > Edit with Elementor

By skipping the 3rd step, you do not give the target system the chance to copy/save the layout information from the original post.

In general, you should only open the normal Elementor Editor if you have completely finished the translation of the 2nd language.

Can you try this ...taking care about step3...and letting me know if you are able to duplicate correctly?

July 2, 2019 at 8:12 am #4124899

mattiasR-3

This worked. But the problem is that my original website ("the simple one" with 2 languages) I'm creating, there's 20 checkboxes+ and tried without checking them (takes a lot of time) and just put Save and Exit - it doesn't take settings with...

I hoped that "Copy all fields from .." would check them all or at least include all the settings as well but it didn't. Next website I'm starting has 4 languages and even if this I'll do manual checking since It's going live in few days .. next one (Real Estate company website) would be too much I think 🙂

Maybe there's possible to create Check All button there with next update 😀 .. or if there's already, let me know. Thx! At least now I know how it will work. Could get this Check all to work, would be lovely. My designer likes to Edit things when sees visually the page so that's why he want's to change everything in Elementor Visual editor. (well, words are different lenghts in different languages etc)

July 2, 2019 at 12:25 pm #4126717

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I know what you mean.

Personally, I use the Chrome extension "Check All"
hidden link

The only caveat of this extension is that it will mark all the checkboxes but I have to "unmark" one and "remark" it in order for the system to recognise it. A small price to pay for the effect desired.

Please try it out and let me know if it works for you.

July 4, 2019 at 3:02 pm #4144737

mattiasR-3

Since this is the only option right now, will make this work.

But will hope this Checkbox will appear soon in WPML as well - should be like 10 min of programming I think 😉 .. not sure I should rewrite WPML plugin files for that but if it won't arrive, I even might try 😀

Thanks for the help,
Mattias

July 4, 2019 at 3:06 pm #4144785

mattiasR-3

So got it sort of working but using outside Extensions (especially browser's since some us Safari, others Firefox and Chrome and everything...) is never the best way. Hope this Checkbox will appear in WPML Plugin itself as well 🙂