This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 5 months ago.

Assigned support staff: Andreas W..

Author Posts
May 13, 2019 at 1:58 pm #3799205

pak-hungP

Hello,

My blog posts have only one language, but the WPML still generate the link for second language( the post with ?lang=en). I don't want the site to generate the blog post link with ?lang=en because the seo diagnosis tool said i have duplicate meta description as shown in the attachment. Please let me know how to tackle it.

Below is the problematic links:
hidden link
hidden link

Thanks
Anthony

May 13, 2019 at 7:10 pm #3801321

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

Do I understand right that you do not wish to have any or some posts availbel on the English site?

It seems that the post has been duplicated from Chinese to English. Please go to Posts and select the English language. Now, delete the repective post or posts.

I would further advise you to change the site URL structure at WPML -> Languages to Language in directories. This will help your SEO rating and provide a better readibility.
https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/

This should solve the issue. Let me know if you need further assistance.

Kind regards
Andreas

May 13, 2019 at 11:30 pm #3802141

pak-hungP

Hello,

I don't have any post in english language. I even didn't create a post page for the english language. The WPML just automatically created these redundant links. Please see the attachment for details. May i know how to tackle the issue.

thanks
Anthony

May 14, 2019 at 3:24 am #3803099

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 14, 2019 at 3:51 pm #3808901

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for the provided credentials.

Did you apply any custom coding to WPML? I can see that the English language is installed and there are existing English pages but you do nto have any language option for posts? this is not WPML default behavior.

It might be that we are handling here with a compatibility issue.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

May 14, 2019 at 4:20 pm #3809085

pak-hungP

you said that my site don't have any language option for posts. Is it because I have set the the post to be not translatable? (as shown in the attachment)

thanks
Anthony

May 14, 2019 at 5:19 pm #3809489

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Yes, indeed. If you enable the translation option there are two posts that are translated into English?

Are you refering to those posts or are there more than two URLs affected?

I am sorry for not beeing able to follow you on the reuest, but the URL hidden link end on the homepage, as expected.

The language selector should only be available for content which does have a valid translation.

Kind regards
Andreas

The topic ‘[Closed] duplicate meta description on the blog’ is closed to new replies.