This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 7 voices.

Last updated by Sam 2 months, 4 weeks ago.

Assigned support staff: Alejandro.

Author Posts
February 11, 2019 at 9:30 am #3181697

wellingtonE

I am trying to: duplicate a post as editor

Link to a page where the issue can be seen: hidden link

I expected to see: that the post was successfully duplicated

Instead, I got: nothing happens

It's simple as described:
- Logged in as editor
- Go to a post
- Go to the language meta box
- Click the duplicate checkbox
- Click the duplicate button
- I see the "loading" graphic - but then, nothing happens

Check this screencast: hidden link

It works for admins, but but not for editors.
I just updated to the newest WPML version.

Best regards
Wellington

March 1, 2019 at 9:26 am #3259202

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i just wanted to update you on the progress of this issue.

Basically the problem is that WordPress editors don't have a required permission needed in order to correctly do what you were trying to do.

Our devs are working on this (they have been doing so for a bit) but the main problem is actually the permissions set by WordPress itself so this situation might take longer that we expected.

There's no need to answer this ticket for now. I'll keep you updated on any changes regarding this issue.

March 8, 2019 at 4:21 pm #3294158
mikaS-3

Hi,

I have same problem, editors can't duplicate because of editor permissions. Admins can.

Workaround would be appreciated since this is long standing issue and should be fixed sooner than later!

Thank You!

Br,
Mika

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/split-duplicate-post-isnt-working-for-editors/

April 1, 2019 at 4:40 pm #3510167
Jean-Francois Ranger

Hello Wordl!

I have the same problem, here are the details hidden link !!!
- I'm already a adminitrator (and not Editor)
- Latest version of all WPML plugins are installed.

April 3, 2019 at 3:43 pm #3528305
heliA-2

Solution: install the "Members"-Plugin and assign "wpml_manage_languages"-capability to the editor.

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/split-duplicate-post-isnt-working-for-editors-5/

April 4, 2019 at 7:55 am #3532943
thomasS-2

Thank you for the hint heliA-2!
You can also put this in your functions.php to avoid installing another plugin:

$role_object = get_role( 'editor' );
$role_object->add_cap( 'wpml_manage_languages' );

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/split-duplicate-post-isnt-working-for-editors-4/

June 19, 2019 at 6:17 pm #4053837

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi there, i just wanted to let you know that the problem is solved in version WPML v4.2.7.1, you can safely update all of our plugins and the problem will go away!

Regards.

September 2, 2019 at 1:29 pm #4497335

Sam

Hi,
Duplicate button was working fine until I upgraded to version WPML v4.2.7.1 and now when I click on duplicate nothing happens.
Please advise.
Sam