Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.39 hours from now. Thank you for your understanding.

This topic contains 8 replies, has 3 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
December 24, 2018 at 1:44 pm #3030580

filipaV-2

My site is in UK and PT. Pages are normally written in UK and then translated to PT by using the menu on the left side. Duplicate page then translate page.

This is what I believe may be causing the issue reported on google console "Duplicate, submitted URL not selected as canonical" as all pages in PT report this error and are not being indexed. How to fix this?

Your assistance is appreciated

December 25, 2018 at 5:45 pm #3032587

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

From what I understand, you first duplicate the page but then translate the content. Is that correct? If so, then the content should not be duplicated.

Is this happening with every page of your site? Or is this only happening with a few pages? What is the link of some page that is happening this problem?

Thank you.

December 25, 2018 at 5:56 pm #3032591

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

First, it is imported for me to mention that WPML does not control the rel=canonical element.
This is being controlled by the Yoast plugin that you are using. More about the rel=canonical element, you can read in the Yoast documentation here.
hidden link

Nevertheless, what might cause this message that you are getting on the Google console is the following. In WPML -> Languages -> Browser language redirect, you have selected the option 'Always redirect visitors based on browser language (redirect to the home page if translations are missing)'. So this might be the reason that Google interprets the translations as duplicated content. We have a message about it in the settings page when you select this option. Please see the attached screenshot. Please read more about it in our documentation at the following links.
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/
https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/

I would like to recommend you to disable this option by choosing ' Disable browser language redirect' and see after a while if the message for the PT pages on the Google console goes away.

Here is a reference to a similar ticket about this issue in our forum.
https://wpml.org/forums/topic/translations-non-indexed-only-english-chosen-as-canonical/

Regards,
Itamar.

December 26, 2018 at 11:03 am #3033823

filipaV-2

Hello Itamar and Bruno

I have Disabled the browser language redirect. I will see how it works and let you know.

Thank you for your assistance

December 26, 2018 at 8:33 pm #3035105

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sure. Thank you for testing this. Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

December 30, 2018 at 8:47 am #3042952

filipaV-2

Hello

I have Disabled the browser language redirect. However, it still has the same message appearing in all translated pages. I normally write in UK and translate to PT. i did not do so on the Nazaré page, and as such appears the UK version with the sae error. See examples below. What to do?

All pages
duplicate, submitted URL not selected as canonical
Last updated: 12/29/18

Duplicate, submitted URL not selected as canonical
Status:
Excluded
Affected pages
21

0
Examples

URL Last crawled
hidden link
Dec 24, 2018
hidden link
Dec 18, 2018
hidden link
Dec 9, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018
hidden link
Nov 1, 2018

January 2, 2019 at 6:18 pm #3050169

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I noticed you are using a cache plugin. Have you tried clearing the cache and waiting a few days to see if Google will index your pages properly?

At the moment, looking at the source code of your site, it seems that hreflang is configured correctly. That is, WPML is pointing correctly to the secondary language page. I'll attach an image for you to see.

Thank you.

January 3, 2019 at 8:48 am #3051607

filipaV-2

Hello

I have cleared cache in both languages and the problem still persists

When inspecting the duplicate URL I get this. It is still considering the translation a duplicate of the original page and as such justs indexes the UK content

PrivacyTerms
hidden link

URL is not on Google
This page is not in the index, but not because of an error. See the details below to learn why it wasn't indexed. Learn more
Page changed?

Coverage
Duplicate, submitted URL not selected as canonical
Discovery
Sitemaps
hidden link
Referring page
None detected
Crawl
Last crawl
Nov 1, 2018, 7:21:05 AM
Crawled as
Googlebot smartphone
Crawl allowed?
Yes
Page fetch
Successful
Indexing
Indexing allowed?
Yes
User-declared canonical

hidden link
Google-selected canonical

Same as user-declared canonical

How to fix this?

January 3, 2019 at 11:58 am #3052277

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This can be a false-positive. Looking at the source code of your site I can not see any errors about duplicate pages. When I access the link you posted above I see:

1. The alternate tags are pointing to the corresponding language;

2. The canonical tags (which as my colleague posted above are from Yoast SEO), then pointing to the current URL. That is, it seems to work correctly too.

Also, since you were previously using the JavaScript redirect option, this can cause problems, as explained in our documentation.

At this moment, as this seems to be working as expected, you will need to wait a few days to see if Google will re-index those pages and if the problem will persist.

Thank you.

The topic ‘[Closed] Duplicate, submitted URL not selected as canonical’ is closed to new replies.