Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:Duplicating pages also duplicates translations

Solution:Please review the following

Relevant Documentation:

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by antonyS-5 2 years, 1 month ago.

Assigned support staff: Bobby.

Author Posts
May 1, 2019 at 2:19 pm #3718531


I'm trying to duplicate some pages in their original languages which are broadly similar in structure and content so they can be amended and finally translated where required, however using Duplicate post it clones the translations too which I specifically do not want to happen.

It wouldn't be much of an issue if there was not a simple mechanism to bulk manage/delete linked translations, however since there is not, cloning a handful of posts [which each have 8 translation] and then going through the multistep deleting process afterward quickly becomes an egregious waste of time.

As per this post, I understand the plugin was updated to specifically do this but despite a lot of searching I cannot find a way to disable this behaviour.

Is there a work around? Perhaps a meta field which could be excluded?


May 1, 2019 at 6:47 pm #3719411


Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please review the following

let me know your results

May 8, 2019 at 8:46 am #3764735


I managed to track the same function down in the plugin before your reply but thanks anyway. For some absurd reason, despite searching for 'WPML' in the support forum filtered by Duplicate Post only, the WordPress site doesn't return the link you sent me!