Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 12, 2019 at 12:23 pm #4742913

hussainB

I am trying to:
Translate simple and variant products on designletters.com.

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link

In general, there are issues when duplicating and translating. Is it correct that i need to go to each language and publish the product? Also the plugin creates issues when duplicating landingpages and in the menu. It does not act the same way in all languages, when I make a change.

October 14, 2019 at 12:29 pm #4749765

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Could you elaborate more about this issue so I can have a better understanding? Also, please attach some screenshots that show the problem.

Kind regards,
Carlos

October 21, 2019 at 1:57 pm #4795031

hussainB

Hi. If you look at the two screen shot, you see the difference on our UK site (The primary where we add new products) in the variants. On the eur site, it does not show the thumbnail pictures. The eur page is duplicated from the uk.

October 21, 2019 at 3:27 pm #4795769

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Could you describe the steps you are following to duplicate the products?

Regards,
Carlos

October 22, 2019 at 2:03 pm #4803109

hussainB

Sure.

1. Add a new product on our uk site (GBP) with a primary sku, create variants from attributes, applies four prices (for each currency) on all variants and variant images. Next I apply a thumbnail image of the variant in swatches.

2. when all these fields are filled, I use the WPML box in the right corner and duplicates it the EUR, USD and GER site. And translates the DKK.

But the swatches are not copied on the duplicated sited. After I wrote you about the same problem when translating it worked with your help.

If i apply the swatches on the duplicated sites instead, it will not save the changes anyway.

I hope this helps.

October 22, 2019 at 4:23 pm #4804261

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

October 23, 2019 at 10:58 am #4810473

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue I kindly ask you to update all outdated plugins and themes and flush all cache memory. This way we will be able to rule out any issue that might be solved already in the latest plugins/theme version.

Regards,
Carlos

October 24, 2019 at 10:47 am #4818741

hussainB

Hi Carlos,

I just updated the plugins that I can in the moment. Could you please have a look at the site now?

October 24, 2019 at 11:22 am #4818939

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I tried to log in the site but the credentials failed. Could you double check if the credentials are still correct?

Regards,
Carlos

October 24, 2019 at 1:41 pm #4820751

hussainB

Hi Carlos,

Sorry we had to do a backup from yesterday, so we do not have the plugins updated anyways.

October 24, 2019 at 2:11 pm #4821171

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Thank you for your feedback, however I still can't login the site using the credentials provided. Could you double check this?

Regards,
Carlos