This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Ahmed Ibrahim 5 months, 3 weeks ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
April 18, 2019 at 8:11 am #3637181

Neil Gauld

I am trying to: Authenticate service

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

April 18, 2019 at 9:06 am #3637525

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

authenticate service

Can you tell me if the issue is the following:
- you activated Brightlines Translation
- when you want to authenticate, you enter API token, however it does not work?

Can you tell me if you confirmed that API token it he correct one, have you tried reaching their support to confirm this?

Regards,
Bruno Kos

April 18, 2019 at 10:37 am #3638335

Neil Gauld

Hello
Thanks for replying.
The 80 characters limit was not enough to explain the problem:
I am clicking "Authenticate" and even though I insert a valid Api token, I get "Authentication didn't work". Also, when I click "deactivate" the service is not deactivated. I can grant access if you need to.

April 18, 2019 at 11:40 am #3638835

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Before I check this myself, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Seventeen as it will tell us if there is an interaction issue with your theme

Please make a full backup of your site before trying this or make these changes on a staging/development site!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

If the above does not yield any results, can you please follow this then:

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

Please also send me API token key, so that I could try myself.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

April 24, 2019 at 9:09 am #3670805

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've escalated this to our 2nd tier and will keep this thread updated as soon as I get any new information from them!

Regards,
Bruno Kos

April 25, 2019 at 8:19 am #3680003

Neil Gauld

Hello. I haven't had any feedback in 1 day. Can you please look into this?
Thank you.

April 25, 2019 at 10:26 am #3681079

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

When issues are escalated to our 2nd tier, not always they get fixed as quickly I'm afraid, as these are usually more complex issues that require additional debugging time.

I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

April 25, 2019 at 2:43 pm #3683603

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the 2nd tier support team.

We have checked your site and it seems that you are connecting your site to our staging service instead of production service, so to resolve this, please follow these steps:

- Deactivate Brightlines Translation Translation Service (in WPML > Translation Services)
- Open wp-config.php file
- Remove this line:

define( 'OTG_TRANSLATION_PROXY_URL', '<em><u>hidden link</u></em>' );

- Also, please remove the line that starts with (if exist):

define('WPML_TP_DEFAULT_SUID',

- After that, you should go to WPML > Settings, refresh the list of Translation Services, go to WPML > Translation Services, activate and authenticate Brightlines Translation.

Please let me know if that helps.
Best regards.