This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 27, 2019 at 2:09 pm

joostv-20

I am trying to:
- Translate the Dutch pages into French and English.

Link to a page where the issue can be seen:
- hidden link

I expected to see:
- Our manually submitted Dutch texts.
We have written Dutch texts for our products. These are stored and are shown at the product-pages. But after changing and saving some parts in the backend (some pictures), the text are overwritten with translations from the English pages.

Instead, I got:
-A translation from the English page. So texts are translated from English into Dutch and French instead of from Dutch to English and French

Additional information:
We have bought a copy of an English WP-site from our Australian colleagues. So we started to translate from English to Dutch. After translation with WPML, we have ajusted the Dutch pages to gramatically correct texts. After that, we have set Dutch to the default language.
But translations are still made from the English pages so our manually written Dutch texts are gone.

May 28, 2019 at 7:06 am #3903151

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ll be helping you with this issue. However, I am unable to reach the dashboard of your installation.

The link you provided does not present the normal WordPress login screen. Do you have another link that you can provide where I can enter the credentials you submitted?

Thanks

May 28, 2019 at 7:10 am #3903233

joostv-20

Dear Yvette,

I'm sorry! Please follow this link: hidden link

Best regards,
Joost

May 28, 2019 at 7:17 am #3903327

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - thank you. I have the login window but when I cut&paste the credentials - they are not working for me. Something wrong with password (?).

I am opening the private are for new credentials.

May 28, 2019 at 7:29 am
May 28, 2019 at 9:04 am #3904555

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thank you for the access. Could you please confirm my understanding of the issue.

You want that all of your current translations be sourced from the NL language. e.g. NL -> EN and NL ->FR

Is this correct?

The "default language" is not the same thing as the "source" language of a post. If you would like to change the source language, you would have to do this in 2 steps.

1. Complete any outstanding updates so that the pencil icons appear.
2. Edit the NL page in manual mode and "disconnect" it as a translation from the original EN version
3. Then "reconnect" the NL version to the original EN version but set it as the new source language.

In this way, you can then change the source of the translations to be NL.

Did I understand the objective correctly?

Also, you should realise that if you are using either the Classic Translation Editor or the Advanced Translation Editor, all edits are stored in a secondary location. If you use these editors, it will indeed load the source language text into the editor only. The contents of the translation editor are only synched to the post when the translation is marked as complete.

May 31, 2019 at 12:56 pm #3930693

joostv-20

Hi Yvette,

Thank you. Yes, you are understanding it correctly.

We've tried to manage the steps that you've mentioned, but can you explain step 2?

Where can we edit the NL page in manual mode and "disconnect" it as a translation from the original EN version?

June 3, 2019 at 8:44 am #3940205

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Please find the following screenshots that explain the process in more detail. I used a product called "Solid Door Freezer<br>BF600.1INOX

1. Toggle editor to manual mode
2. Switch languages to NL
3. Disconnect by setting "Translation of" to "none"
4. Reconnect to EN verison of product and also select to set new source lang to be "NL"
5. Update post.

Note, I realise that this is a bit tedious but this is the correct online way to do the change from the dashboard. You can also edit the database directly but you will need to be proficient in SQL to do this. The table that you would touch woudl be "icl_translations" table and you it would require that you know the post_types and ids of the entries you want to change.

June 3, 2019 at 1:34 pm #3942873

joostv-20

Hi Yvette,

Thanks for the clear explanation. I've tried it myself and it works perfectly now.
As I understand from your message, I've to do every product separately this way?

There is no bulk option to do all products in the way you explained?

Best regards,

Joost

June 3, 2019 at 3:45 pm #3943973

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes. You understood correctly that there is no "bulk" tool to do this. Your option is to manually modify the entries in the database table icl_translations.

Here is more information about the WPML table structures
https://wpml.org/documentation/support/wpml-tables/

Specifically for each set of table entries linked by a common "trid" value, you want to change the NL entry to have the source language of "NULL" and the EN entry to have the source language of "NL".

The topic ‘[Closed] Dutch is set as default, but translations are automatically made from English’ is closed to new replies.