Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Using the Enfold theme we put buttons on the page to link to other pages. The link targets are defined as dynamic links.

The translated page should again have the links set as dynamic links to the respective target.

Instead, I got: The links are set as manual links. Manual links do not update when the slug or path of a page changes.

Solution: Adding the necessary XML in WPML -> Settings -> Custom XML Configuratio tab solves the issue.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 4 years, 3 months ago.

Assisted by: Carlos Rojas.

Author Posts
March 13, 2020 at 6:32 pm #5682817

olafM-4

Using the Enfold theme we put buttons on the page to link to other pages. The link targets are defined as dynamic links.

Link to a page where the issue can be seen: hidden link

The translated page should again have the links set as dynamic links to the respective target.

Instead, I got: The links are set as manual links. Manual links do not update when the slug or path of a page changes. That is bad news. A mistake. Please forward it to the compatibility team.
We need a patch quickly.

dynlinks.PNG
March 16, 2020 at 12:15 pm #5693177

olafM-4

Hi Bobbie, I hope you can still work on this with Corona no longer just a beer brand. We still need help to solve this problem. It gives us a lot of broken links. The WPML Sticky Links does a poor job these days.

March 16, 2020 at 3:55 pm #5694863

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to back-up the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

March 16, 2020 at 5:51 pm #5695661

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
Thank you very much for the information provided.

I will take a deeper look at the issue and I will get back to you as soon as I have an answer.

Regards,
Carlos

March 17, 2020 at 10:25 am #5700291

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,

I added the code for the shortcode of the buttons in WPML -> Settings -> Custom XML Configuration. Now when you translate the page you will be able to translate the advanced tab which contains the post type (page) and the ID of the page.

Please translate the Test page using the correct page IDs for the german version and let me know if the issue persists.

Regards,
Carlos

March 17, 2020 at 11:18 am #5700915

olafM-4

Hi Carlos, you are a Genius. I am not sure why I called you Bobbie before. The solution works. The link field shows up in the ATE with the pageID. We now finish the translation without changing the pageID and the page works. Magic. Checking the translated page then in the Page Editor shows the link is set as a dynamic link to the corresponding translated page. Perfect.
However, WPML should do that without the patch. It used to do it. We now add the Custom XML for single button and full width button as well.
Please let us know if WPML can fix that in the next update. It was working before.

March 17, 2020 at 12:20 pm #5701473

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
I'm glad to hear that the issue is solved 🙂

I believe that you might be referring to Sticky Links. Please take a quick look at our documentation on Sticky Links and let me know if its what you are expecting: https://wpml.org/documentation/getting-started-guide/sticky-links/

Regards,
Carlos

March 17, 2020 at 4:48 pm #5703845

olafM-4

Hi Carlos,
yes, the Sticky Links is a related topic. For sure they work now. What I am saying is that you may want to alert the compatibility team to update the ATE. We should not need the Custom XML configuration with a theme that is labeled as compatible.

March 18, 2020 at 1:49 am #5705965

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Oh, I understand what do you mean now 😀

Yes, I will update our compatibility specialists about this ticket and ask them to take a look at a compatibility level. If they find a solution it will probably include in a future release of our plugin.

Please let me know if you need further assistance and I will be more than happy to help.
Best regards,
Carlos

March 18, 2020 at 9:02 am #5708577

olafM-4

Greetings from house arrest in Italy. Carlos did a great job. He understood the issue quickly and found a remedy. Great. I would nominate Carlos to be the "Supporter of the Week".

March 18, 2020 at 1:00 pm #5711089

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi,
Thank you for your recommendations!

Please don't hesitate to contact us if you need our help in the future with WPML.
Greetings from quarantine in Spain 😀
Carlos

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.