This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bobby 3 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
July 1, 2019 at 6:03 pm #4121539

lars

I am trying to: update sitepress and string to the latest version

Link to a page where the issue can be seen: hidden link

I expected to see: three flags for sv, en, and de.

Instead, I got: Server Error 500 and a white page.

WPML Multilingual CMS | Documentation | WPML 4.1.4 release notes

Version 4.1.4 | Av OnTheGoSystems | Besök tilläggets webbplats
Detta tillägg gick inte att ladda på rätt sätt. I räddningsläge är det pausat.

Ett fel av typen E_ERROR uppstod på rad 2496 i följande fil: /var/www/vhosts/scanfill.se/httpdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php. Felorsak: Uncaught ArgumentCountError: Too few arguments to function SitePress::terms_clauses(), 1 passed in /var/www/vhosts/scanfill.se/httpdocs/wp-includes/class-wp-hook.php on line 288 and exactly 3 expected in /var/www/vhosts/scanfill.se/httpdocs/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:2496 Stack trace: #0 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/class-wp-hook.php(288): SitePress->terms_clauses(Array) #1 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #2 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/class-wp-term-query.php(654): apply_filters('terms_clauses', Array, Array, Array) #3 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/class-wp-term-query.php(288): WP_Term_Query->get_terms() #4 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/taxonomy.php(1178): WP_Term_Query->query(Array) #5 /var/www/vhosts/scanfill.se/httpdocs/wp-includes/category.php(57): get_terms(Array, Array) #6 /var/www/vhosts/scanfill.se/httpdocs/wp-conte

***

[OK] BackupBuddy Version = 8.4.18.0
[OK] WordPress Version = 5.2.2
[OK] MySQL Version = 5.7.26
[OK] MariaDB Version = n/a
[OK] AddHandler in .htaccess = Ingen, saknas
[OK] PHP Version = 7.3.6
[OK] PHP max_execution_time (server-reported) = 60
[OK] Tested PHP Max Execution Time = 62 secs
[OK] BackupBuddy PHP Max Execution Time = 60 secs
[WARNING] Reported PHP Memory Limit = 256M (local) / 128M (master)
[WARNING] Tested PHP Memory Limit = 128 MB
[WARNING] PHP Maximum File Upload Size (server-reported) = 8 MB
[OK] PHP Error Logging (log_errors) = disabled [Test]
[OK] PHP Error Log File (error_log) = unknown
[OK] PHP Display Errors to Screen (display_errors) = disabled
[OK] Zip Methods = exec, ziparchive, pclzip
[OK] Database Dump Methods = php, commandline
[OK] Site Size = Unknown
[OK] Site Size (Default Exclusions applied) = Unknown
[OK] Site number of files = Unknown
[OK] Site number of files (Default Exclusions applied) = Unknown
[OK] Database Size = 129.68 MB
[OK] Database Size (Default Exclusions applied) = 78.8 MB
[OK] Average Write Speed = 5 MB/sec
[OK] Guesstimate of max ZIP size = 299.76 MB
[VARNING] Http Loopbacks = disabled (enable alternate cron)Warning #9038: Connected to server but unexpected output: `Webbplatsen har tekniska problem.`. Code: `500 Internal Server Error Internal Server Error`.
[Okej] wp-cron.php Loopbacks = enabledActive test success
Returned: `` with code `200 OK`.
[Okej] Loopback Domain & IP = hidden link => 85.30.129.243
[Okej] WordPress Cron = enabled
[Okej] WordPress Alternate Cron = disabled (default)
[OK] Disabled PHP Functions = opcache_get_status
[Okej] PHP function: mysql_connect() = disabled
[OK] PHP Register Globals = disabled
[OK] PHP Magic Quotes GPC = disabled
[OK] PHP Magic Quotes Runtime = disabled
[OK] PHP Safe Mode = disabled
[OK] PHP API = fpm-fcgi
[OK] PHP Architecture = 64-bit
[OK] Http Server Software = Apache
[OK] Server Load Average = 1.94, 1.74, 1.78
[OK] PHP SSH2, SFTP Support = no, no
[OK] WordPress ABSPATH = /var/www/vhosts/scanfill.se/httpdocs/
[OK] Operating System = Linux (Linux b-http-lin-1.teleservice.net 4.4.0-142-generic #168-Ubuntu SMP Wed Jan 16 21:00:45 UTC 2019 x86_64)
[WARNING] Active WordPress Plugins = sitepress-multilingual-cms/sitepress.php, acf-repeater/acf-repeater.php, advanced-custom-fields/acf.php, advanced-post-types-order/advanced-post-types-order.php, backupbuddy/backupbuddy.php, cookie-notice/cookie-notice.php, ithemes-sync/init.php, theme-blvd-layout-builder/tb-builder.php, theme-blvd-sliders/tb-sliders.php, theme-blvd-widget-areas/tb-sidebars.php, theme-blvd-widget-pack/tb-widget-pack.php, theme-blvd-wpml-bridge/theme-blvd-wpml-bridge.php, wordfence/wordfence.php, wordpress-seo/wp-seo.php
[OK] PHP Process User (UID:GID) = u5506-1-5 (10075:1004)
[OK] BackupBuddy Deployment API wp-config setting = Disabled (Setting Undetected)

***

July 1, 2019 at 9:31 pm #4122221

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

as you are updating the plugins from an older version of WPML (more than a few past releases ) i recommend for this update to perform it manually

to do a manual update please follow these steps:

https://wpml.org/downloads/

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugins from our servers and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

let me know your results after the manual update , does the error persist ?

The topic ‘[Closed] E_ERROR: Uncaught ArgumentCountError’ is closed to new replies.