This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 4 months, 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 15, 2019 at 9:35 pm #3820333

Tamara Kellogg

I am trying to: have Twitter Card displayed by Easy Social Share Buttons use our Spanish Twitter account hashtag and username, rather than the English (default) ones.

Link to a page where the issue can be seen: hidden link. (and click on the Twitter button: you'll see how the hashtag is in English.)

I expected to see: that I could find the string for the ESSB where the hashtag and username for the Twitter card would be changeable. I used the Translate Texts in Admin Screens option, and I thought I found them, but when I added them and then went back to the String Translation screen, they couldn't be found.

Instead, I got: an inability to translate the strings for the ESSB Twitter card hashtag and username.

May 15, 2019 at 10:59 pm #3820469

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Do I understand right that you located the string on "translate text in admin screens" but it was not added successfully to String Translation?

It is possible to fix this by adding a Custom XML Config for the language config file of the plugin at WPML -> Settings -> Custom XML Configuration.
https://wpml.org/documentation/support/language-configuration-files/#admin-texts

In case you need any assistance I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 20, 2019 at 5:18 pm #3849289

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I received the URL and FTP access but sadlz not the credentials for accessing the wp-admin and further the credentials for logging into WordPress.

Please verify and provide access again. You next reply is set to private by default.

Kind regards
Andreas

May 24, 2019 at 6:23 pm #3887047

Tamara Kellogg

Hello Andreas, please forgive my delay in answering. I now have the login information, but as this reply does not specify it is private, I edited the previous private reply to include the login information for the WordPress admin.

Thank you.

May 25, 2019 at 10:11 pm #3890203

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was able to locate the URL string at String Translation "translate strings in admin texts" but for some kind of issue they were not been added to String Translation.

Before we take any further steps I would kindly like to ask you to update WPML and its add-ons as the current version is outdated and the issue was most lilkely solved in one of the latest versions.

Please download the latest versions of WPML Multilingual CMS 4.2.6 at https://wpml.org/downloads.

Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.6 again.

Then go to Plugins -> Install -> Commercial and download the add-ons. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

Leave me short notification once the plugins are up to date. Please also make sure that any other plugin and the theme are using their latest verions.

I would alsow advise you to update WordPress at Dashboard -> Updates.

Kind regards
Andreas

May 30, 2019 at 4:48 pm #3925103

Tamara Kellogg

Hello Andre. the plugins and WordPress are all updated. I tried again to extract the admin string but it did not show up on the String Translation page after doing so.

I appreciate your ongoing help.

May 30, 2019 at 9:35 pm #3926289

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I am not sure why the strings are not added. It is indeed possible to still add string manually from different plugins and i tested the issue in a minimal setup on the staging, means with a default theme and only the ESSB plugin, WPML and our add-ons.

I would like to test the plugin on a new WordPress installation. Please install the plugin Easy Social Share Buttons for WordPress 5.6.1 onto the following test site:

One Click Login: hidden link

Further, just in case please take note of the following. We lately had another issue in regards to the plugin, where a widget created by the plugin was not translatable. The solution here was to create one widget for each language, which is possible due tothe widget language settings at Appearance -> Widget. I thought it might be worth mentioning it even if it out of scope for the current issue.

Please leave me a short notification once the plugin was installed in the test site. I will then test it about the issue and if necessary take further steps.

Kind regards
Andreas

May 30, 2019 at 9:44 pm #3926299

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Additional to my last message.

I found a workaround by adding a custom XML configuration at WPML -> Settings -> Custom XML Config. Please have alook at String Translation where you will now find the string: hidden link

Please translate the string to Spanish and let me know if this solved the issue.

Additional string will need to be added manually for now, in the same way as I did for profile_twitter string. The information fo thsi string comes from:

String Translation -> translate strings in admin text -> easy-social-share-buttons3

More information here:
https://wpml.org/documentation/support/language-configuration-files/#admin-texts

Let me know if you need further assistance.

Kind regards
Andreas

The topic ‘[Closed] Easy Social Share Buttons can't translate hashtag and username’ is closed to new replies.