This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Ricardo Alday 1 year ago.

Assigned support staff: Ricardo Alday.

Author Posts
September 23, 2018 at 9:50 pm #2758992

El mo

I am trying to: The Search settings text is not translating by itself on Chinese.. But on russian it does it by itself

Link to a page where the issue can be seen: "hidden link"

I expected to see: Russian page does itself "hidden link "

Another issue. When translating properties.. Example the back-end settings is like 5 bed room 5 bathroom..
When i click the translate button the "existing settings from english" don't transfer over instead it is blank....

September 25, 2018 at 8:31 am #2762992

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Are you referring to the options that I show in the attached screenshot?
Please see the attached screenshot.

If the above is indeed the issue, then I can see that currently, WPML is not controlling those translations. The automatic translations that you can see for the Russian language are probably coming from the .mo files of the plugin. I say that WPML is not controlling those translations because only WPML Multilingual CMS (our core plugin) is installed on your site. If you go to WPML -> Theme and plugins localization, you will be able to see that the only chosen option is 'Don't use String Translation to translate themes and plugins'. This is because that the Strings Translation add-on is not enabled on your site. With the Strings Translation add-on, you will be able to translate those strings into Chinese. But it will not happen automatically. You can read more all about this in our documentation here.
https://wpml.org/documentation/getting-started-guide/theme-localization/
I can see that also the EasyPropertyListings plugin's documentation encourages users to translate the plugin's strings to other languages. You can see it here.
hidden link

You are also writing: "When i click the translate button the "existing settings from english" don't transfer over instead it is blank...."

I do not understand exactly the problem. Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area. In any case, you might be able to translate those strings with the Strings Translation add-on. Please read about it in our documentation here. https://wpml.org/documentation/getting-started-guide/string-translation/

If it important for me to mention that the Easy Property Listings plugin by Merv Barrett is not in our compatibility list here. https://wpml.org/documentation/plugins-compatibility/. Not being on this list does not mean that it is not compatible it just means we do not know yet if it is.

Regards,
Itamar.

September 25, 2018 at 8:36 pm #2765223

El mo

I have been duplicating "properties" but the image in the gallery are not showing up. Upon reviewing the html code i notice the image urls are the wrong url or don't exist ??

If i go to wordpress media library i see alot of "blank" photos upon inspection they are wrong url " hidden link" <-- No .jpg ? Also part of the url has zh-hans ?

September 26, 2018 at 7:34 am #2766152

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Is the initial issue with the untranslated strings into Chinese solved already?

I'm confused and not sure that I understand the problem now.
Is this a new problem that you are having with the Easypropertylistings plugin?

For duplicating existing media for other languages, please do the following.
1. Go to WPML -> Settings -> Media Translation (scroll to the bottom).
3. Make sure that the following options are chosen.
- Translate existing media in all languages
- Duplicate existing media for translated content
- Duplicate the featured images for translated content
4. Press the 'start' button and wait for the process to finish.
Then the images should be duplicated to the other languages.
Is it working for you?

Regards,
Itamar.

September 26, 2018 at 9:08 am #2766563

El mo

I have done 1,3,4 before. To replicate my problem..

Go to translation management "select a property" then "duplicate content" .. So lets say Property A has 10 pictures... after duplication.. i check the property and only 2 out of 10 pictures display. So i inspect the HTML Code and the image URL are wrong or not the same as the main language (english )

Second way is to "add translation manually" by clicking the + Button however this yields the same thing, missing pictures.

In short... if i duplicate .. only some pictures show up.

September 26, 2018 at 9:44 am #2766678

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Could you please provide me with temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access to a test site where the problem is replicated.

Thanks,
Itamar.

September 26, 2018 at 11:24 am #2766955

El mo

I attached another image to hopefulyl explain the issue.

Right now... the other issues i described previously seems to have randomly fixed itself, however when i use the + button to translate the it does not translate all the images or it seems the .. featured image don't show up.

September 26, 2018 at 2:30 pm #2767682

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I could not log into your site. I've received a wrong username message.

Are the following options in the 'Languages' section on the editing screen checked?
- Duplicate uploaded media to translations
- Duplicate featured image to translations
Please see the attached screenshot.
If not, then please check them and see if the featured image and other media are being duplicated to translated post.

Please the access details and share with me the correct details if you still need help from me.
I'm enabling private message again.

Thanks,
Itamar.

September 26, 2018 at 4:05 pm #2768028

El mo

Any update ?

September 26, 2018 at 4:40 pm #2768151

El mo

So it seems like a bug.. Lets say i have 1 property without any Featured image.

1. Then i update it to have a featured image.
2. Duplicate to chinese
3. Run media translation hoping it will fix the missing featured image ?
IT does not fix the missing featured image in the chinese section ?

September 26, 2018 at 8:12 pm #2768607

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details. They are correct now.

I've checked this post. hidden link and I saw that the featured image was missing on the Chinese translation here. hidden link. So I've just updated the translation, and now it shows. Please see the attached screenshot. I'm sorry if I've forgotten to tell you that after checking those options you should also update the translation of the product?

Can you please do the same for the other products' translations that are missing the featured image.

Thanks,
Itamar.

September 27, 2018 at 9:49 am #2769987

El mo

There is 1 particular property or maybe a few like this where i translate it but only some of the images show and the rest are broken url
See Here > hidden link
Original Here > hidden link

Notice alot of the pictures missing ? If you check the html code you can see the other pictures are there but the URL's are wrong

September 27, 2018 at 11:18 am #2770262

El mo

Going into wordpress media library under Russia or Chinese i see the broken images there

I have since manually deleted it.

September 27, 2018 at 5:24 pm #2771350

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Currently, when I go to the links that you gave me, I can see the same amount of images (8) in the gallery. And when I view the gallery in both languages all the images are available. Please see the attached screenshots.
Has this issue been fixed by deleting the images from the Media Library?
Do you still need help with this issue?
If you do still need help, then please explain to me how you have created this gallery?
How can I reproduce this problem on your site?

Thanks,
Itamar.

September 28, 2018 at 8:47 am #2772958

El mo

HEY! I seem to have fixed the problem by deleting the broken images in media library. I have to delete them in English/Chinese/Russian.

You might be wondering how did this problem even happen ? This problem happens after you run the "media translation" .

Im not sure if this is going to be a problem for me in the future but certainly seems like a bug on wpml side because it is producing broken images.

I also believe that if you were to run media translation now it would break the existing property images so i definitely do not want to run media translation anymore.

TLDR: I found out that if i delete all the broken images from english/chinese/russia duplicating post or translating post is not an issue after that and all the images appear intact.

The topic ‘[Closed] Easypropertylistings Translation’ is closed to new replies.