This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.83 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: We added the Czech language and translated the pages to it. The URL slug is /cs but we need to change it to /cz

Solution: In this case you have two options: 1.- Add a custom language in WPML -> Languages -> Edit Languages link 2.- Change the language code in the database by following the steps described in this link: https://wpml.org/documentation/support/editing-wpmls-languages-table/#editing-languages-directly-in-the-database

Relevant Documentation:

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 26, 2019 at 1:54 pm #4290013

avneetJ

Tell us what you are trying to do?
We added the Czech language and translated the pages to it. The URL slug is /cs but we need to change it to /cz
Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

July 26, 2019 at 2:45 pm #4290197

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

In this case you need to go to WPML -> Lanuguages -> Site Languages -> Click on 'Edit languages' link -> Change the language tag column from cs to cz -> Save the changes.

Kind regards,
Carlos

July 29, 2019 at 5:11 am #4296991

avneetJ

Hi Carlos,

There is no such option to change the language code of the czech language. See attached screenshot.

Here is the URL: hidden link. We need to change it to hidden link

Please assist us with the best solution.

July 29, 2019 at 6:47 am #4297225

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Please change the value in the 'hreflang' column, the first column starting from the right.

Regards,
Carlos

July 29, 2019 at 7:26 am #4297341

avneetJ

Hi Carlos,

I've changed the hreflang to cz but it is still opening this url: hidden link

Regards

July 29, 2019 at 7:30 am #4297357

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 29, 2019 at 7:57 am #4297585

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Thank you very much for the information provided.

In this case you have two options:
1.- Add a custom language in WPML -> Languages -> Edit Languages link
2.- Change the language code in the database by following the steps described in this link: https://wpml.org/documentation/support/editing-wpmls-languages-table/#editing-languages-directly-in-the-database

Regards,
Carlos

July 29, 2019 at 8:03 am #4297597

avneetJ

Hi Carlos,

Adding a custom language means i have to add a custom language with the czech locale and then add each product and pages in the new custom language?

July 29, 2019 at 8:07 am #4297629

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Yes, that's correct.

Regards,
Carlos

July 29, 2019 at 9:57 am #4298513

avneetJ

My issue is resolved now. Thank you!

July 29, 2019 at 11:35 am #4299239

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos