This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Edit or delete copied from the original posts

Solution: issue is resolved now after changing fron clasical editor to Gutenberg.

Relevant Documentation:

This topic contains 17 replies, has 2 voices.

Last updated by dimitriosV-3 11 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
October 18, 2018 at 5:41 am #2826660

dimitriosV-3

When I try to edit or delete copied from the original posts with the normal process it takes too long time, the website finishes its memory resources and stops.

October 18, 2018 at 7:25 pm #2829369

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if possible please help me to fully understand the issue.

if you go to Pages -> and try to "duplicate" a page into the secondary language , do you get a 503 or error 500 ?

does this happen for all of your pages or just one specific page ?

also does this happen again when you go to Pages and then try to delete a page ?

please share with me a screenshot of the error.. if the page is blank right click and inspect the page , do you see any errors within the console ?

October 19, 2018 at 1:20 am #2829894

dimitriosV-3

I can not update or delete copied from the original posts. When I press the bottom update it takes a lot of time and the site stops with the message resource limit is reached.

When I press move to the trush I am getting the message “OOPS! THAT PAGE CAN’T BE FOUND.”

It might be related to my other issue “the unsuccessful importation from the qtranslate x” which has not been resolved yet.

October 19, 2018 at 9:21 am #2831341

dimitriosV-3

Reply to your questions:

1. if you go to Pages -> and try to "duplicate" a page into the secondary language , do you get a 503 or error 500 ? ---No I do not get such error. The page is created but when I press the bottom «translate independently» in a duplicate document It takes too much time and does not give results. When I try to leave the page becomes white.

2. does this happen for all of your pages or just one specific page ?also does this happen again when you go to Pages and then try to delete a page ?
---I do not know as I have not created many copied pages. The problem is with some copied pages, e.g. hidden link
When I try to edit or to delete, I am getting the following message 508 “Resource Limit Is Reached - The website is temporarily unable to service your request as it exceeded resource limit. Please try again later.”

3. Maybe we have to complete the proper migration from qtranslate which has not been completed yet @laura and the wpml translator creates several malfunctions.

October 19, 2018 at 6:41 pm #2832849

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i will contact my colleague to see if this might be related , but if possible i would like to take a closer look and try to replicate the issue on my local environment as well.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

October 22, 2018 at 12:04 pm #2837904

dimitriosV-3

I am writing the history of my actions that might be helpful to you.
My website was working with an older wordpress version, an older theme, and “qtranslate plus” very well without problems.
I updated to the latest wordpress version and realized that the TinyMCE Advanced plugin was not working due to the presence of the qtranslate plus plugin.
I changed the theme to a clone of twenty seventeen and the qtranslate plus to qtranlate x. still the TinyMCE Advanced editor was not working but with qtranslate x I could at least change from English to Greek home page not to each page’s translation but to the home page of the new theme.
I deactivated the qtranslate x and installed wpml and the plugin qtranslatex importer.
I tried 4 times to migrate to wpml without success. It took me more than 12-15 hours each time and the migration finally was stopping.
In the new situation, I have several malfunctions - some old posts were missing (provably not migrated), the menus, posts and pages were in two languages, the TinyMCE Advanced plugin was not working again, I could not delete copied from the original posts, the gallery did not open the pictures.
I configured the wpml and corrected the double language in the menu and some posts and pages manually.
I sent letter for support.

October 22, 2018 at 9:35 pm #2839900

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for the access details !

i am currently not able to replicate the issue as described.

i went to posts -> test a few posts by clicking "update" and i was able to update the posts as expected.

the process did not take any longer than expected and it was successfully finished without any errors

please let me know if i am missing a step in replicating the issue.

October 23, 2018 at 4:59 am #2840746

dimitriosV-3

The problem occurs only to a few posts like the one given below
"The Mrs. India Worldwide - 2018 pageant had a strong Greek touch"
I noticed that under Edit Post” “Add New”
Appears the following message
Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case.

October 24, 2018 at 5:28 pm #2847389

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello ,

i went to the post "The Mrs. India Worldwide - 2018 pageant had a strong Greek touch" clicked edit and the updated first the original post, then i went to the translation , published it and updated it and it worked as expected.

this was all done automatically using the WP guttenberg editor as you can see in my screenshots.

hidden link

October 24, 2018 at 8:04 pm #2847786

dimitriosV-3

Thanks Bobby,
I have deactivated the plugin classic editor and activated Gutenberg and now 2 posts that I checked have been updated as expected.
I have also noticed that another page when I change language from English to Greek the categories widget continues to be displayed in English (and not Greek as it should).
I am sending the link to the page and a photo to check it.
hidden link

October 25, 2018 at 7:37 am #2848878

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i was able to replicate the categories issue on my test server.. i have reviewed some recent known issues and this is currently being worked on by our developers to resolve

at the moment i believe you can go to WPML->Settings-> select to use WPML Translation Editor

when using the Translation Editor the categories should be carried over as expected during translation.

October 25, 2018 at 10:25 am #2849426

dimitriosV-3

Ι do not find your suggested option WPML->Settings-> select to use WPML Translation Editor
The problem with the different language widjet continues to be present when I change language, but when I edit directly the post without changing language the category appears in the same language

October 25, 2018 at 5:48 pm #2850645

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If you go to Posts -> Greek -> and then from within there access the translation edit screen the categories are in the correct language ?

i have test this locally and it stills shows the wrong language

as this is a knonw issue that our developers are working on to fix at the moment , if this workaround is working OK for you i suggest for now until we update you with an official fix that this might be the suggested way

but if you would like to use the Translation Editor (side to side) makes translation a bit faster

go to WPML-> Settings -> Use the Classic Translation Editor

this will allow you to use the Translation Editor (side to side) for the translation.

October 25, 2018 at 7:26 pm #2850946

dimitriosV-3

I do not see this option
WPML-> Settings -> Use the Classic Translation Editor
Is it available with my wpml program?

October 25, 2018 at 8:09 pm #2851030

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

My apologies i did not notice your Multilingual Blog license ...to you have the translation editor the Translation Management plugin is required which i believe is available in the WPML CMS and Agency licenses

if it was available for your license it would be found here

-> https://wpml.org/account/downloads/