This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm trying to edit my Home page in Elementor after 2 languages are done. However when I tried to edit the text or remove some widget in Elementor then click "SAVE", it appears "Server Error (500 error)."

Solution: This issue seems related only to that specific page. i was able to solve this using the steps below:

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

- Go to Plugins > All Plugins and disable all WPML plugins. Please disable also the SG optimizer plugin (you can re-enable it and test after all steps if you want).

- Enable all WPML plugins again

- Go to WPML > Support > Troubleshotting and click on the following buttons:

--- Clear the cache in WPML

--- Remove ghost entries from the translation tables

--- Set language information

--- Fix post type assigment for translations

--- Recreate ST DB cache files

- After that, install and activate this plugin: https://wordpress.org/plugins/duplicate-page/

- Go to Pages > All Pages and duplicate the home

- Edit the page and translate to all languages. It should work normally

- Go to Settings > Reading and set the duplicate as the new homepage

- Delete the old page

This topic contains 15 replies, has 2 voices.

Last updated by ka-lunK 11 months, 3 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
October 24, 2018 at 11:31 pm #2848061

ka-lunK

Tell us what you are trying to do?

Hi, this is Lawrence again... I'm trying to edit my Home page in Elementor after 2 languages are done. However when I tried to edit the text or remove some widget in Elementor then click "SAVE", it appears "Server Error (500 error)."

Is there any documentation that you are following?

I tried to un-check all translation. I tried to choose manually edit in "Translation editor options". I didn't see any errors pop up in the debug monitor.

Is there a similar example that we can see?

What is the link to your site?
larossy.com

October 25, 2018 at 9:36 am #2849285

ka-lunK

I found where it get conflicts and (maybe) irreversible.
Basically I want my translate pages look the same as default page, so I go to "Custom fields" of the "Edit page" section then check all to "translate once". Honestly I don't really know what are those strings mean but I just want to copy the style from default page then I can fine tune for each language.
After that when I edit the default page in Elementor, it gets 500 server error. It doesn't fixed even I check the "Custom fields" back to "Don't translate". I have to go to WPML->Support->troubleshoot->Reset and deactivate WPML to start it again.
Am I doing anything wrong here?

October 25, 2018 at 9:58 am #2849350

ka-lunK

Update:

This doesn't work: WPML->Support->troubleshoot->Reset and deactivate WPML to start it again.

I have to: deactivate all plugin and Reset WPML as above, then activate it all.

Not sure which parts gone wrong...

October 25, 2018 at 3:53 pm #2850379

ka-lunK

Anyone?

October 26, 2018 at 12:32 pm #2852977

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @ka-lunk, welcome to the WPML support Forum!

Please enable WP_Debug on your website, it will display more details about the error: https://wpml.org/documentation/support/debugging-wpml/

After that, run the same steps again. It should display more details on the error screen (instead of the generic error 500). Please send us a screenshot of the error message.

It would also be nice if you activated wp_debug_log and sent us the content. It is located in the /wp-content/ folder. You can use pastebin to send us the content of the wp debug log: https://pastebin.com/

All the best,
Diego

October 26, 2018 at 4:26 pm #2853657

ka-lunK

Hi Diego,

Thank you for your reply.

First of all, I ran the same steps on check "copy once" in custom fields at bottom of "Home page". It looks like theme related (sidebar layout, contect layut, header layout etc). Then it appears 504 error instead of 500 error, and no debug.log was generated.

Then I decided to active the cache and query monitor plugin (as those were activated for 500 error). Then ran again the same steps, the 500 error appears and a debug.log generated. Please have a look: https://pastebin.com/bWQXBKDp

After that, I deactivate the query monitor plugin which I think the one causing 500 error. Then 504 cloudflare page appears.

October 29, 2018 at 12:48 pm #2857985

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

According to your debug log, what caused this error was lack of memory:

[26-Oct-2018 15:57:34 UTC] PHP Fatal error:  Allowed memory size of 805306368 bytes exhausted (tried to allocate 20480 bytes) in /home/larossy1/public_html/wp-content/plugins/query-monitor/classes/Backtrace.php on line 95

Could you please increase the WP memory limit to 512mb? Currently this memory is set to 256mb:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Please let me know if it worked for you.

Kind regards,
Diego

October 29, 2018 at 3:35 pm #2858634

ka-lunK

I try to deactivate the query monitor and the 500 error gone but 504 error.

October 29, 2018 at 6:53 pm #2859260

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Did you increase your memory? Did you see any new error in debug.log due to error 504?

If you want, we can replicate your website on our server to check if the same issue occurs. If it is okay, please let me know and I'll send you the instructions.

Regards,
Diego

October 29, 2018 at 7:08 pm #2859274

ka-lunK

Sorry I've misread the steps and I'm working on it.

October 29, 2018 at 8:19 pm #2859448

ka-lunK

Hi Diego,

I've increased the memory limit to 768M, which is the max I could go for. Also, the timeout time of WPML increased as well
However, 500 error happens this time when the elements in custom fields checked for "copy once" then edit the page.
In addition, it only appears in "Home page", other pages work fine. There is no debug.log generated for this 500 error...
I'm ready to duplicate the website for you guys.

Best,
Lawrence

October 30, 2018 at 2:06 pm #2862147

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I sent you the instructions in a private message. please let me know if it worked.

Regards,
Diego

October 30, 2018 at 3:10 pm #2862416

ka-lunK

Hi Diego,

The migration is ready. Please try to edit the "Home" page in elementor or at wordpress dashboard. It will load a long time then 500 error.

Best,
Lawrence

October 31, 2018 at 2:57 pm #2866395

ka-lunK

Any update????
You guys are working extremely slow, one day one reply????

October 31, 2018 at 3:16 pm #2866448

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks. After several tests I found that the issue seems related to the page. If I try to edit the homepage, the same error occurs (timeout). But If I duplicate the homepage I'm able to edit/translate the new page normally:
- hidden link
- hidden link

Here are the steps I used, which you can replicate on your website:
IMPORTANT: Please backup your site first before making any change, this is important for security reasons.
- Go to Plugins > All Plugins and disable all WPML plugins. Please disable also the SG optimizer plugin (you can re-enable it and test after all steps if you want).
- Enable all WPML plugins again
- Go to WPML > Support > Troubleshotting and click on the following buttons:
--- Clear the cache in WPML
--- Remove ghost entries from the translation tables
--- Set language information
--- Fix post type assigment for translations
--- Recreate ST DB cache files
- After that, install and activate this plugin: https://wordpress.org/plugins/duplicate-page/
- Go to Pages > All Pages and duplicate the home
- Edit the page and translate to all languages. It should work normally
- Go to Settings > Reading and set the duplicate as the new homepage
- Delete the old page

Feel free to check and test our copy site if needed. I will send the instructions through a private message.

Please let me know if it worked for you.

Regards,
Diego