Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by vladimirZ-7 6 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 16, 2019 at 7:57 am #3822841

vladimirZ-7

I am trying to: get rid of "edit post language switcher" from home page but keep the Switcher on the posts.

Link to a page where the issue can be seen: hidden link
hidden link

I expected to see: no Switcher on the home page banner.

Instead, I got: i see on the home page that breaks my design.

May 16, 2019 at 8:14 am #3823027

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please go to WPML > Languages > Links to translation of posts, uncheck / disable the option "Show links above or below posts, offering them in other languages"
This will remove the language switcher above each page and post.

I hope this helps you better, Please let me know if you need further assistance

Kind regards
Raja

May 16, 2019 at 8:16 am #3823059

vladimirZ-7

the point is that I do not want to remove The Post switcher from posts. I need to remove only from home page.

May 16, 2019 at 8:22 am #3823083

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Ah, that I missed, Sorry about that,

This can be achieved by a custom CSS snippet. Since you are using Ocean WP theme paste the below CSS snippet in Appearance > Customize > Custom CSS/js


.home .wpml-ls-statics-post_translations {
 display:none;
}

Kind regards
Raja

May 16, 2019 at 8:32 am #3823257

vladimirZ-7

My issue is resolved now. Thank you!