This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Rob Coers 5 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 3, 2019 at 10:20 am #3733035

Rob Coers

I am trying to: change WooCommerce text

Link to a page where the issue can be seen: on the checkout page for Spanish

I expected to see: translateable text

Instead, I got: can't find the strings

Here is a screencast of what I am experiencing.
hidden link

Thanks,
Rob

May 3, 2019 at 11:10 am #3733665

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Rob,

Thanks for the detailed explanation about the issue. 🙂

It seems like the string is not registered or removed from the ST tables.

Please go to WPML > Theme and plugin localization > Plugin localization,
Select WooCommerce and click on "Scan select plugin for strings" Wait for the process to complete, Clear cache and check if you can see the missing string in the String Translation table.

Let me know the results.

Kind regards
Raja

May 3, 2019 at 6:26 pm #3737431

Rob Coers

Hello Raja,
I followed your steps, but it didn't work as hoped. Cleared cache with CTRL+F5 but it's still as in my video.
Any ideas?
Rob

May 6, 2019 at 7:34 am #3745497

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share temporary access to your site. Let me take a closer look. I have enabled the private fields to securely share the details.

Kind regards
Raja

May 8, 2019 at 5:55 am #3763953

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thanks for the access, I have checked this in detail, In the String Translation page search for the string "Make your payment" you will see the bacs_gateway_description string (Screenshot attached).

The problem might be the string search is unable to match the special characters, I will notify it to the second tier. However, for your case, I think you can use the above workaround.

Kind regards
Raja

May 8, 2019 at 12:02 pm #3766403

Rob Coers

My issue is resolved now. Thank you!