Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by torsten3d 9 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
February 27, 2019 at 4:50 pm

torsten3d

I have the native menu with some html i it (<i class="fa fa-home"> Startseite).
I started to translate that menu and reenter the html. I coould to that for some elements and now don't have tha ablity to edit the text anymore. Not in original or in the translated menu.

February 28, 2019 at 1:00 pm #3255350

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've just visited the menu section on your site, and I cannot see any HTML in the menu items as you show in your screenshot. Please see the attached screenshot that I attach.
Have you solved this issue already?
If you didn't solve it, then please try the following.
WPML is slightly not updated on your site, could you please update it to the latest version (4.2.4) and see if it helps to solve the issue.

If it does not help, then please tell me, how I can replicate the issue on your site.
please tell me what to do in steps (do 1. 2. 3...)

Thanks,
Itamar.

February 28, 2019 at 2:11 pm #3255639

torsten3d

Hi Itamar,

please have a second look. It's the "Footer"-Menu.
"Hauptmenu" makes use of the build-in Icon-options from the Uncode theme. So there is no need for HTML.
The additional-footer-menu hast to be tweaked with html to get the same effect.

Kind regards
Torsten

February 28, 2019 at 5:35 pm #3256844
torsten3d

Hi Itamar,

after changing the Font-Size for the heading with the counter (the bigger size caused a line break than counting) i just see the german words on the English frontend again.

Additionally the text block below is also german again and not visible in the translation editor anymore!

Best regards
Torsten

New threads created by Itamar and linked to this one are listed below:

https://wpml.org/forums/topic/split-german-string-show-on-the-english-page/

February 28, 2019 at 5:37 pm #3256859

torsten3d

This also affects some other textblocks on further pages like hidden link i didn't opened the last hours...

February 28, 2019 at 10:48 pm #3257627

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Torsten.

I'm sorry for missing the fact that you are referring to the Footer menu.

I've checked the Footer menu on your site, and I see no problem updating the text of any menu item. You just need to expend the menu item, make the changes and save the menu.
Please see the attached screenshot footer-menu.jpg
Can you edit the menu's text?

For the other issue, please see this ticket.
https://wpml.org/forums/topic/split-german-string-show-on-the-english-page/

Regards,
Itamar.

February 28, 2019 at 11:06 pm #3257652

torsten3d

Hello Itamar,

the problem with the footer menu could be solved.
After your succesfull editing i had tested it in Chrime instead of Firefox. There it works like it should and i can edit the Menu Text.

The issue just seems to be in Firefox (latest, Windows 10). I also cleared the browser cache for that site.
Klicking on the arrow for the menu item i get redirected to the initial view of the primary menu.
So i could solve this for me by using Chrome for that.

March 1, 2019 at 12:57 am #3257814

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Great! I'm glad that this issue is solved now.

Could you please mark this ticket as resolved?

Thanks,
Itamar.

March 1, 2019 at 7:54 am #3258791

torsten3d

My issue is resolved now. Thank you!
Best greets from Wernigerode, Germany